Results 1 to 8 of 8

Unable to remove PS pulley

This is a discussion on Unable to remove PS pulley within the External Engine forums, part of the LSx Technical Help Section category; So I went to Autozone and rented the kit. I followed the instructions from the link below but the pulley ...

  1. #1
    Junior Member
    Join Date
    Apr 2015
    Location
    chicago
    Posts
    11

    white
    2001 pont trans am

    Unable to remove PS pulley

    So I went to Autozone and rented the kit. I followed the instructions from the link below but the pulley will not come off. Did I get the wrong kit am I doing it wrong?






  2. #2
    Junior Member
    Join Date
    Apr 2015
    Location
    chicago
    Posts
    11

    white
    2001 pont trans am

    (UPDATE) So once I figured out how to use the tools the pulley came right off. Replacing the pump was easy as was removing the lines. I've added a cooler to it and replaced the lines. The only concern I have are the pressure lines where they attached to the bottom. I tighten them as much as I could but they didn't seem to go all the way in. I notice the metal lines that come out of the connectors can be moved side to side. Is this normal? Or should they not be able to move? If not then what am I doing wrong?

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Which line are you referring to? Can you post a pic?

  4. #4
    Junior Member
    Join Date
    Apr 2015
    Location
    chicago
    Posts
    11

    white
    2001 pont trans am

    Attachment 26263

    i was able to tighten the sending hose so it doesn't move. The return line unfortunately I damaged when I attempted to tighten it

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Ok - you were referring to the fittings in the rack.

  6. #6
    Junior Member
    Join Date
    Apr 2015
    Location
    chicago
    Posts
    11

    white
    2001 pont trans am

    Quote Originally Posted by pajeff02 View Post
    Ok - you were referring to the fittings in the rack.
    Yes and unfortunately i damaged one of them which that part happens to be discontinued

  7. #7
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    You can get hoses custom made at lots of garages and truck places. Our local NAPA will make them.

  8. #8
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    TurnOne has an awesome pulley wheel that you no longer need to remove it to access the bolts. Happiest purchase I've ever made.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unable to view threads in Mostly anything goes forum...
    By firemandan1700 in forum Request and Feedback
    Replies: 8
    Last Post: 05-19-2012, 09:59 AM
  2. unable to look at for sale section ?
    By Dus10o in forum Request and Feedback
    Replies: 1
    Last Post: 11-22-2009, 02:36 AM
  3. Unable to edit FS thread
    By nhra-trans-am in forum Request and Feedback
    Replies: 2
    Last Post: 12-18-2008, 02:03 PM
  4. Help: Unable to Open Internet Exporer....Please Help!
    By SAGGIN in forum Computers / Gaming
    Replies: 20
    Last Post: 08-14-2008, 04:02 AM
  5. Unable to Read posts
    By CrimsonNJ in forum Request and Feedback
    Replies: 1
    Last Post: 03-06-2006, 02:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •