Results 1 to 4 of 4

ticking??

This is a discussion on ticking?? within the External Engine forums, part of the LSx Technical Help Section category; hey, what happened is i had a ticking in my motor. thinking it was a failing lifter i kept driving ...

  1. #1
    Junior Member nativetalon's Avatar
    Join Date
    Dec 2007
    Location
    pembroke, nc
    Age
    34
    Posts
    59

    silver & black
    2000 TA 1979 TA

    ticking??

    hey, what happened is i had a ticking in my motor. thinking it was a failing lifter i kept driving it for a while. i finally saved up enough to change my lifters rockers and rods and during the install we found my intake was busted or blown inside the port. not thinkin it could be fixed and trying 2 get my car out the shop i went ahead and bought the fast 102 thinking it would help. well, it fixed the busted intake problem but i lost a noticeable amount of power since my bbk 80mm was decked. and also the ticking is still there and i hope someone can explain wat it is. does my cam have a worn lobe? if so, how can i tell and would this cause a lifter to fail or a rocker to keep coming aloose? or can there be another problem i am overlooking. so far i have changed my whole top end other than the cam, and before i go back into it i am going to fix my bbk intake and put it back on until i can find a good set of heads. also if i hav a custom cam, 601/612 lift. not sure on duration., and the lobe is worn, can it be fixed or should i invest in a new one and what kind do you suggest on best sound and power for street/strip?

  2. #2
    Member TA98's Avatar
    Join Date
    Mar 2009
    Location
    Maryland
    Posts
    863

    Black
    1998 Trans Am

    you may have a blown header gasket. That usuallys gives a ticking sound.

  3. #3
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    When you say ticking, does it sound like a sewing machine?
    What lifter are you running and how much preload do you have on the lifters?
    Has your oil pressure dropped any since you got the ticking?

    I just replaced my lifters... I had one explode and it sounded almost like a broken rod and oil pressure dropped about 15psi

  4. #4
    Junior Member nativetalon's Avatar
    Join Date
    Dec 2007
    Location
    pembroke, nc
    Age
    34
    Posts
    59

    silver & black
    2000 TA 1979 TA

    i just replaced the whole top end other than the heads and cam, new rods arms and lifters (comp perf) 22ft/lbs is what they were suppose to be torqued to if that's what u mean by preload. my oil pressure runs around 40, is that ok? i have a ls6 ported oil pump but haven't put it on yet, didn't want too much oil pressure. and it was ticking when i bought the car so idk what average oil pressure was before ticking.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. bad ticking
    By Firebirdformula99 in forum Internal Engine
    Replies: 11
    Last Post: 04-23-2012, 06:51 PM
  2. Ticking sound
    By GottaHaveLS1 in forum General Help
    Replies: 12
    Last Post: 09-07-2007, 02:48 PM
  3. ticking
    By barryTA in forum External Engine
    Replies: 3
    Last Post: 01-17-2007, 10:26 AM
  4. ticking
    By stangereater in forum Internal Engine
    Replies: 14
    Last Post: 09-23-2006, 09:14 PM
  5. ticking
    By daas5 in forum Almost Anything Goes
    Replies: 7
    Last Post: 04-06-2006, 11:58 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •