Results 1 to 4 of 4

Thermostat issue.

This is a discussion on Thermostat issue. within the External Engine forums, part of the LSx Technical Help Section category; Ok so a few weeks ago not knowing much about the ls1 motors i ordered a thermostat from jegs off ...

  1. #1
    LoudMouth SStriker's Avatar
    Join Date
    Jul 2006
    Location
    Westminster/Sykesville, Maryland
    Age
    28
    Posts
    512

    Red
    2000 Trans Am

    Thermostat issue.

    Ok so a few weeks ago not knowing much about the ls1 motors i ordered a thermostat from jegs off of ebay. It said for LS1s. So it shows up and its just the thermostat, see i assumed the thermostat and the housing were two peice like my old SBCs. So i pull the stock housing off and start trying to remove the thermostat(it looekd like a two peice from the way the colors were). Needless to say i broke the stocker and couldnt get a new one for atleast a few days so i dremeled the stock housing out to make the new thermostat work. Come to find out it was for 04 and newer ls1s.... Thanks jegs for not describing right.

    So anyways, the car ran normal temp so i assumed my Custom job had worked. Now my tuner showed up today and i changed my fan settings but it wont go any lower the 210.... shouldnt it run around 180-190 instead? Could it be that fact it was mid 90's outside today? Or do i need to get a new thermostat...

    I assume im going to have to buy the correct 160 now

  2. #2
    Member
    Join Date
    Aug 2005
    Location
    Burlington, NC
    Posts
    203

    Black
    2000 Camaro SS

    If you don't reprogram the fans to go on at a lower temp. the reading will remain about 210. Reprogram your PCM to change the fans temps. as follows;

    Fan 1 on at 184, off at 175.
    Fan 2 on at 194, off at 185.

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    The '99 and up gauges aren't accurate. I have my fans set the same as suggested in the previous post (w/160) - gauge still reads just below 210.

  4. #4
    LoudMouth SStriker's Avatar
    Join Date
    Jul 2006
    Location
    Westminster/Sykesville, Maryland
    Age
    28
    Posts
    512

    Red
    2000 Trans Am

    Quote Originally Posted by JEB View Post
    If you don't reprogram the fans to go on at a lower temp. the reading will remain about 210. Reprogram your PCM to change the fans temps. as follows;

    Fan 1 on at 184, off at 175.
    Fan 2 on at 194, off at 185.
    I had it programed, come to find out it was the heat beucase tonight my temps got too low. My predator gives alot better reading on temp then my gauge. I will set my fans to that tommarow.

    thanks guys.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle issue.. may be tune issue.. help?
    By okiels1 in forum General Help
    Replies: 2
    Last Post: 12-07-2016, 03:17 PM
  2. pvc issue... vacuum leak....tune issue?
    By okiels1 in forum General Help
    Replies: 3
    Last Post: 03-05-2016, 10:10 AM
  3. Help: tranny issue think it might be planetary issue
    By nerisls1 in forum Automatic Transmission
    Replies: 6
    Last Post: 03-05-2009, 10:32 PM
  4. just did a 180 thermostat
    By BLACK 97 SS in forum External Engine
    Replies: 5
    Last Post: 02-11-2008, 07:05 PM
  5. 160 thermostat
    By Danger731 in forum General Help
    Replies: 2
    Last Post: 04-13-2007, 03:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •