Results 1 to 4 of 4

thermostat

This is a discussion on thermostat within the External Engine forums, part of the LSx Technical Help Section category; though this is kinda a double post, I figure more of you would see it here in this section. -------------------------------------------------------------------------------- ...

  1. #1
    Junior Member hartsmike's Avatar
    Join Date
    Feb 2008
    Location
    tennessee
    Posts
    86

    thermostat

    though this is kinda a double post, I figure more of you would see it here in this section.

    --------------------------------------------------------------------------------

    Picked up my new (used) 94 TA last night. I'd driven it before. Noticed that the heater never warmed up to blow warm air.-33 degrees outside. Drove it 20 miles or so to town. However, when I was in town, I let it idle for a couple of minutes and the temp gauge got warm. Past the half way point. Do you guys know if the thermostate sticking open caused it?



    Also, I looked this morning at the set up. Is it easy to chage the thermostat? It seemed all you had to do was unhook the front air induction and take the two bolts out.

  2. #2
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by hartsmike View Post
    though this is kinda a double post, I figure more of you would see it here in this section.

    --------------------------------------------------------------------------------

    Picked up my new (used) 94 TA last night. I'd driven it before. Noticed that the heater never warmed up to blow warm air.-33 degrees outside. Drove it 20 miles or so to town. However, when I was in town, I let it idle for a couple of minutes and the temp gauge got warm. Past the half way point. Do you guys know if the thermostate sticking open caused it?



    Also, I looked this morning at the set up. Is it easy to chage the thermostat? It seemed all you had to do was unhook the front air induction and take the two bolts out.

    Could have just been the rediculous cold weather? Or the thermostat. Perfect time to get a 160* or 180*!!!

    2008 Z06 - Velocity Yellow - OEM

    2017 Silverado Z71 5.3 - OEM

    2002 Z06 - Electron Blue Metallic - D1 - E85 - 701 rwhp 687 rwtq **sold**

    2002 Z28: M6 NBM - cam and boltons - 396rwhp 357 rwtq **sold**

  3. #3
    Alabama Member bamaz28's Avatar
    Join Date
    Jan 2008
    Location
    heart of dixie
    Posts
    1,215

    06 Jeep Grand Cherokee.
    02 superchipsZ28 M6(sold)

    may not have a thermostat in it

  4. #4
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Almost sounds like someone has put a cooler thermostat in the car and didn't program the fans to work with it.

    Running a 160 stat will do this. Stays cool as long as the car is moving,,,but in traffic with no air flow it will begin to heat up until the fan temps are reached,,,which is way up there around 220 degrees or so.

    It's easy enough to check the thermostat and see whats going on.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 160 thermostat
    By V8MUSCLE in forum External Engine
    Replies: 6
    Last Post: 10-02-2009, 12:53 AM
  2. No thermostat?????
    By ggino85 in forum General Help
    Replies: 5
    Last Post: 08-03-2009, 11:22 PM
  3. 160 thermostat
    By 13nickels in forum General Help
    Replies: 0
    Last Post: 07-07-2008, 06:58 PM
  4. thermostat mod
    By Brent in forum General Help
    Replies: 6
    Last Post: 03-17-2008, 04:09 PM
  5. Thermostat?
    By '00T/A in forum External Engine
    Replies: 13
    Last Post: 09-27-2007, 09:35 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •