Results 1 to 14 of 14

stretched throttle cable?

This is a discussion on stretched throttle cable? within the External Engine forums, part of the LSx Technical Help Section category; don't know if this is an LS1 thing or not. and i'm pretty sure this isn't a demand for the ...

  1. #1
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    Question stretched throttle cable?

    don't know if this is an LS1 thing or not. and i'm pretty sure this isn't a demand for the Bump-Stop mod.

    but when i press my peddle, the throttle body only opens like half or 2/3 of the way? it feels like there is a lot of slack in it too...is it possible it's been stretched? I don't know if it's the original one or not. Thanks in advance!

  2. #2
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    hey all! i know a lot of you couldn't answer this, but i took my car to the local LS1 pro-shop and they fixed it really quick by adjusting a little clasp on the throttle cable. It's easy to see, i'd shoot pix but it's freakin cold out. Just follow the cable from the TB toward the cruise control and you'll encounter a little square in the line. Pop it open, adjust and BOOM: now it actually opens the TB all the way!!!

  3. #3
    Member
    Join Date
    Feb 2002
    Location
    SO CAL
    Age
    35
    Posts
    153

    Black
    2002 WS6

    good to know!!

    I'll be checking tomorrow

  4. #4
    Likes twisty roads bene's Avatar
    Join Date
    May 2006
    Location
    England but from TX
    Posts
    803

    Light Pewter Metallic
    2K Camaro Z28

    Quote Originally Posted by third_shift|studios View Post
    Just follow the cable from the TB toward the cruise control and you'll encounter a little square in the line. Pop it open, adjust and BOOM: now it actually opens the TB all the way!!!
    How did you adjust this???

    I'm only showing 80% WOT when I mashed the gas pedal. I need to fix this. I feel like I'm being robbed.

  5. #5
    MOTOR CITY MARO' SSTODD's Avatar
    Join Date
    Nov 2005
    Location
    LIVONIA,MICHIGAN
    Age
    51
    Posts
    786

    PEWTER
    2000 CAMARO SS #3821

    Mine was doing this before, not reaching 100% on the scanner. I traced the cable back towards the firewall and found my clamp or clasp loose. I pinched it back tight and had full throttle control again 0-100%.

  6. #6
    Likes twisty roads bene's Avatar
    Join Date
    May 2006
    Location
    England but from TX
    Posts
    803

    Light Pewter Metallic
    2K Camaro Z28

    Pinched it back tight? Can you take a picture?

  7. #7
    MOTOR CITY MARO' SSTODD's Avatar
    Join Date
    Nov 2005
    Location
    LIVONIA,MICHIGAN
    Age
    51
    Posts
    786

    PEWTER
    2000 CAMARO SS #3821

    I can try but I'm working crazy hours now. It was above the passenger valve cover. The cables are going from the throttle body over to the box next to the battery (either cruise control or traction control?) and they curve near this clampand I could see it binding and hear it clunking a little when moving the throttle.

  8. #8
    Likes twisty roads bene's Avatar
    Join Date
    May 2006
    Location
    England but from TX
    Posts
    803

    Light Pewter Metallic
    2K Camaro Z28

    With this pictures, can you point it out where it is?




  9. #9
    MOTOR CITY MARO' SSTODD's Avatar
    Join Date
    Nov 2005
    Location
    LIVONIA,MICHIGAN
    Age
    51
    Posts
    786

    PEWTER
    2000 CAMARO SS #3821

    Quote Originally Posted by bene View Post
    With this pictures, can you point it out where it is?

    Click for full size

    Click for full size
    Right between the yellow and red dipsticks and under the STB, see the black plastic that looks like the end of a pen. You should have a plastic clamp that pinches tight right there.

  10. #10
    Likes twisty roads bene's Avatar
    Join Date
    May 2006
    Location
    England but from TX
    Posts
    803

    Light Pewter Metallic
    2K Camaro Z28

    Found it. lol. I got it fixed. Thanks!

  11. #11
    MOTOR CITY MARO' SSTODD's Avatar
    Join Date
    Nov 2005
    Location
    LIVONIA,MICHIGAN
    Age
    51
    Posts
    786

    PEWTER
    2000 CAMARO SS #3821

    Very cool,

  12. #12
    VERITAS / AEQUITAS T/A Addicted's Avatar
    Join Date
    Jul 2009
    Location
    Ohio (Union county)
    Age
    41
    Posts
    92

    Pewter
    2002 T/A WS-6

    I took her out for a cruise today, and felt like she just wasnt opening up right. Felt like when I pushed it to the floor it just wasnt fully opening. When I got back to the house I popped the hood and found quite a bit of slack in the cable. (enough that I can pick it up and set it outside of the half circle track its setting in) So I know it needs adjusted, and I head to the computer to see if one of you guys has posted something telling me how and bam I find this thread.

    Great easy enough, right.

    I run back out to the garage remove my strut towerbrace cause its under the FRC's (so I was thinking) and trace the entire cable to the firewall and its not there. I come back in for a second look and realize the years your discussing has Traction Control. Mine does not, its a 2002 WS-6. I had the TB changed a few months ago but put her up with running her. I'm sure this is what I need to do. Does anyone know if there is another way to adjust this?? Or am I missing something??

  13. #13
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Ya non traction control cars dont have the adjustable box there. Not sure how to adjust those.

  14. #14
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Thread is 5 years old.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Throttle cable
    By hamburger68 in forum External Engine
    Replies: 8
    Last Post: 02-05-2011, 08:18 AM
  2. 5.3 Throttle cable
    By dizzball in forum New Member Introductions
    Replies: 0
    Last Post: 06-18-2009, 09:24 AM
  3. Throttle cable???
    By drummer52910 in forum General Help
    Replies: 3
    Last Post: 02-21-2008, 08:23 PM
  4. throttle cable
    By silverz28camaro in forum Camaro / SS
    Replies: 3
    Last Post: 03-04-2007, 02:30 AM
  5. Throttle Cable Help
    By 90nova in forum General Help
    Replies: 3
    Last Post: 02-09-2006, 02:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •