Results 1 to 2 of 2

Squealing noise after underdrive pulley install...

This is a discussion on Squealing noise after underdrive pulley install... within the External Engine forums, part of the LSx Technical Help Section category; I had an SLP underdrive pulley installed on my 2000 Formula w/ 48k miles, and after it was put on, ...

  1. #1
    Member bbfirebird's Avatar
    Join Date
    Jul 2005
    Location
    AZ
    Age
    38
    Posts
    113

    Navy Blue Metallic
    2000 Formula hardtop

    Squealing noise after underdrive pulley install...

    I had an SLP underdrive pulley installed on my 2000 Formula w/ 48k miles, and after it was put on, a squeaking noise has developed. It didn't start right away, it started maybe a week after I had it put on. Originally, it was only noticeable when the engine was cold, and only when the car was accelerating. Over the past weeks though it has progressed to the point where it can be heard all the time, and it is louder/squeakier than it was before. I've tried spraying belt dressing on it, which quiets it somewhat, but not much, and any benefits that it does get are gone within an hour or so. The belts I had put on were Goodyear Gatorbacks. I did notice right before I had it installed that the crank belt was .5 inch shorter than recommended. I had them put it on anyway, and it fit fine.

    Can anyone tell me what this noise might be? Worn tensioner, bad idler pulley, wrong size belt?

    Also, can someone give me the proper size (and preferably part number) for the belts to use with the SLP underdrive pulley?
    2000 NBM M6 Formula hardtop.
    Catback, lid, etc.

  2. #2
    Member bbfirebird's Avatar
    Join Date
    Jul 2005
    Location
    AZ
    Age
    38
    Posts
    113

    Navy Blue Metallic
    2000 Formula hardtop

    anyone?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Squealing noise in 2000 LS1 - help! desperate
    By 162hotrod in forum Internal Engine
    Replies: 10
    Last Post: 06-13-2012, 01:17 PM
  2. Underdrive pulley install question
    By KDZRGROWN in forum External Engine
    Replies: 4
    Last Post: 10-19-2008, 12:24 PM
  3. How difficult to install ASP underdrive pulley.
    By KIXASS in forum External Engine
    Replies: 12
    Last Post: 09-15-2007, 04:47 PM
  4. Squealing pulley?
    By 98ramairguy in forum External Engine
    Replies: 25
    Last Post: 09-05-2006, 03:52 AM
  5. underdrive pulley install question
    By tx77015ls1 in forum General Help
    Replies: 4
    Last Post: 05-09-2006, 09:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •