Results 1 to 9 of 9

Someone Help me please!!!

This is a discussion on Someone Help me please!!! within the External Engine forums, part of the LSx Technical Help Section category; I have a 99 camaro SS it has 70K on it and a 6spd, everytime im crusing down the street ...

  1. #1
    Junior Member CWDUB4's Avatar
    Join Date
    Feb 2011
    Location
    CA
    Posts
    8
    99 camaro SS

    Someone Help me please!!!

    I have a 99 camaro SS it has 70K on it and a 6spd, everytime im crusing down the street and give it some gas to go faster the car stutters, like kinda chokes!! this usually happens around 2000-2500 rpm... changed the fuel filter and spark plugs still nothing worked can anyone help me please??? there are no codes poping up on the dash either, i have a feeling it might have to do something with the o2 sensor or the cats, cuz the cats sounds like shit... so do my mani. but im no expert, so please again i would appreciate all the advice!! thanks guys

  2. #2
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    I dnt knw exactly what could be the problem. But if u hear something on the cats when you hit the gas. Thar should be the problem.
    My car had the passenger side cat messed up. It used to make noise. The car was kinda lazy. I replaced it the problm was gone.

    You should try to clean the MAF. It might help a little
    00 ss blk m6 " STOCK" strano springs, slp bilstein shocks, adj LCA, adj panhard bar, relocation brackets, 2 point SFCs welded,OEM zo6 rims black, magnaflow exhaust, CME exhaust,E/cutout, slp grille, custom front plate mount, HIDs, whistler mod, side moldings delete, slp air lid, ported and polished TB, strut tower brace, 3.73s gears, and some other parts to list!
    next to come,4.10s,ls7 clutch, ms3 or 228r cam, ported 243s, ls6 intake, ls6 oil pump. ls2 timing chain, longtube headers no cats, with a tune..
    02 tahoe Z71 blacked out
    00 jeep grand Cherokee limited on 22s.
    07 Dodge Charger R/T Inferno Red, Sold
    98 z28 red m6 sold
    07 zx6r ninja flat/black sold
    08 zx6r ninja sold

  3. #3
    Junior Member CWDUB4's Avatar
    Join Date
    Feb 2011
    Location
    CA
    Posts
    8
    99 camaro SS

    yea i cleaned it out and nothing helped... i think it might be the cats and an
    O2 sensor but i just wanted to see if anybody else had this type of problem, thanx tho!!

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Sounds like its time for LTs and a CAT delete.

    When's the last time you cleaned your MAF?

    When you did the plugs did you hear the clicks? Plugs are 2 clicks and the Coil is 1, (or vice verse) If not seated then can cause issues.

    Also if you are having O2 Sensor problems or a miss-fire you will have a code come up.

    At 70K the CATS have been know to go bad. I'm not sure how they would sound because I've gone the LT/CAT Delete long time ago.

  5. #5
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    I think you've answered your own questions.. "cuz the cats sounds like shit"..

    Rear 02's are meaningless.. If it is the cats it will eventually throw a catalyst code..

    Performance will not be effected weather the rear 02's work or not..

    But a clogged or internally broken cat/s WILL...

    Have it scanned to see if any codes were ever logged..

    Just my .02
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  6. #6
    Junior Member CWDUB4's Avatar
    Join Date
    Feb 2011
    Location
    CA
    Posts
    8
    99 camaro SS

    i cleaned out the MAF like 2months ago, and im gonna be going back to CA so I NEED cats, so i guess imma have to get new ones... will the cats make the LT's sound like crap also??

  7. #7
    Senior Member raynor139's Avatar
    Join Date
    Aug 2007
    Location
    Greensboro, NC
    Age
    33
    Posts
    1,319

    Pewter
    2002 Trans Am WS6 M6

    Quote Originally Posted by CWDUB4 View Post
    i cleaned out the MAF like 2months ago, and im gonna be going back to CA so I NEED cats, so i guess imma have to get new ones... will the cats make the LT's sound like crap also??
    Cats can help refine and quiet down loud LT setups.

  8. #8
    Junior Member
    Join Date
    Aug 2005
    Location
    Ohio
    Age
    37
    Posts
    11
    I would be shocked if both cats went out at 70k miles. Does your exhaust rattle or get red hot? If it was the cats you would have problems past the RPM interval that you describe. What is your fuel pressure?

  9. #9
    rice,its what's fo dinner LeadFarmer's Avatar
    Join Date
    Jan 2010
    Location
    Arlington,Texas
    Age
    26
    Posts
    815

    Silver/Black
    00' z28-R.I.P 00' WS6 M6

    usually what happens when your cats are messed up is you'll get some kind of odd grinding/rattling coming from the exhaust at a particular rpm range. Which was true in my case. But it is odd that you aren't throwing codes.
    If you really want to be sure you could run the car with open manifolds and see what happens, I think that'd be the only sure fire way to tell.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •