Results 1 to 7 of 7

Slp Lid

This is a discussion on Slp Lid within the External Engine forums, part of the LSx Technical Help Section category; Does anyone have pics of how their lid is installed cuz i installed that with the smooth bellow today and ...

  1. #1
    Junior Member
    Join Date
    Sep 2006
    Location
    Laguna Beach, CA
    Age
    42
    Posts
    93

    Red; 58,000 org. miles
    1999 Camaro Z28, M6....

    Slp Lid

    Does anyone have pics of how their lid is installed cuz i installed that with the smooth bellow today and something just doesn't seem right...i don't know..............thanks!

  2. #2
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    its your smooth bellows that is screwing everything. try driving for a while to heat up the bellows and everything then...lid and bellows and such will fit on alot easier. but i'd get rid of the bellows..it doesnt do shit.
    mods- suncoast creations hood with functional lt1 style airbox, ls6 intake, QTP longtube headers, QTP ORY, UMI SFC, Adj. LCA with relo brackets, UMI adj. panhard bar, Koni SA and strano springs,Torq Thrust M 17s 9.5 and 10.5 with nitto 555Rs, tuned by Frost
    Quote Originally Posted by Modulistic View Post
    sometimes you get owned, sometimes you own.

  3. #3
    Junior Member
    Join Date
    Sep 2006
    Location
    Laguna Beach, CA
    Age
    42
    Posts
    93

    Red; 58,000 org. miles
    1999 Camaro Z28, M6....

    everything fits...iot just seems like something is missing

  4. #4
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    mine fits great try putting the lid in and snap it down, then tighten the bellows to the TB last.
    1999 Camaro SS/ Pewter/ #1775 - LS1 6-speed - Predator 3 Custom Tune - Pro 5.0 - LS7 Clutch - 3.90's - Koni's - Strano Springs and Sway Bars - SFC's - Full UMI Chassis and Suspension - LS6 Intake PnP TB - ARH LT's and Kitty Ran Away - Magnaflow.

    12.6 at 112

    http://www.fquick.com/Tyler_LS1

  5. #5
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    Quote Originally Posted by chrombs13 View Post
    everything fits...iot just seems like something is missing
    ummm....did you put the filter back in? Not sure what you mean by missing

  6. #6
    Junior Member
    Join Date
    Sep 2006
    Location
    Laguna Beach, CA
    Age
    42
    Posts
    93

    Red; 58,000 org. miles
    1999 Camaro Z28, M6....

    thanks Kage....it just seemed weird how the neck of the lid connected....no rubber, just a screw tight..........thanks again and yes the filter is in there!

  7. #7
    Junior Member
    Join Date
    Sep 2006
    Location
    Laguna Beach, CA
    Age
    42
    Posts
    93

    Red; 58,000 org. miles
    1999 Camaro Z28, M6....

    thanks Tyler

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •