Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Slp lid

This is a discussion on Slp lid within the External Engine forums, part of the LSx Technical Help Section category; just installed an SLP LID today, everything went fairly smooth but my question is are u suppose to just remove ...

  1. #1
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    Slp lid

    just installed an SLP LID today, everything went fairly smooth but my question is are u suppose to just remove the resonator tube completely from under the car? at first i just left the tube an noticed it whistled really loud an there was vaccum coming from the hose.. then just removed the hose completely an drove the car around an eventually the whistle just stopped on its on own. also i noticed the car now idles at a slightly higher RPM then before, is this normal? also it almost feels as if the car is a little more sluggish then before for w/e reason.. sorry for the noob question im new to ls1's
    Last edited by darkside01; 04-25-2010 at 07:35 PM.

  2. #2
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    think you're talking about the air pump. Its for emissions. The noise i think you're hearing is the pump sucking air and pumping it into your exhaust manifolds. After a while the pump shuts off.

  3. #3
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    which is exactly what happened then, thanks for the verifying that.

  4. #4
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Quote Originally Posted by darkside01 View Post
    which is exactly what happened then, thanks for the verifying that.
    no problem, where in Fl are you at?

  5. #5
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    just north of orlando

  6. #6
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Quote Originally Posted by darkside01 View Post
    just north of orlando
    thats cool, in down in S fl.
    was just curious

  7. #7
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    There should be a piece of hose and a grommet to couple the secondary air hose to your new lid. If not, you may have the wrong year lid for your car. This connection only allows filtered air into the secondary air system. In lieu of connecting it to your lid, you can insert a small breather filter into the end of the hose and zip tie it to something.

    As stated, the system only operates for a short period of time after cold start-up. It pumps air into the exhaust manifolds to help bring the catalytic converters up to operating temp sooner. A lot of people remove the system in its entirety from their cars -- so long as emissions laws are not a problem. Upon removal, you need a tune though to keep your SES light from activating.

  8. #8
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    the year specified was 98-02 soo i assumed there wasnt a difference in the part? the kit just came with a round plastic gromet that plugged the hole in the lid where the hose would go.. then i just took the resonator tube itself off the car but left the pump there. so this is not correct ur saying? its not throwing any codes BTW.

  9. #9
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    It won't throw codes as the system is still operating. It just does no have filtered air entering the pump. This is probably the best picture I have of it hooked up to my SLP lid:


  10. #10
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    ahh ok.. nope my kit came with no such thing lol emissions here are not a problem so should i just leave it or actually take the pump itself out? does this have any effect on performance or just purely an emissions thing?

  11. #11
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by darkside01 View Post
    ahh ok.. nope my kit came with no such thing lol emissions here are not a problem so should i just leave it or actually take the pump itself out? does this have any effect on performance or just purely an emissions thing?
    Purely an emissions thing imo. At the very least, hit the parts store and see if you can find a breather filter to shove in the end of the hose. If you choose to remove it, this thread will help you with the process: Secondary Air: Diagnosing and Removal

  12. #12
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    im having headers along with other things installed shortly along with a tune, i could just have him remove the pump all together i guess

  13. #13
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    That will make a difference on the headers you order -- emissions vs. non-emissions. I installed headers last month and deleted the secondary air system. I like a clean look under the hood and getting rid of all that clutter really helped.

  14. #14
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    i re-checked my order sheet and does say 98-99.... i don't know how i overlooked that! soooo i guess ill hafta either try an rig up some kinda connection or like u said look for a filter to fit in the damn hose.

  15. #15
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Quote Originally Posted by darkside01 View Post
    i re-checked my order sheet and does say 98-99.... i don't know how i overlooked that! soooo i guess ill hafta either try an rig up some kinda connection or like u said look for a filter to fit in the damn hose.
    no biggie
    could be worse, you could have ordered a v6 lid

  16. #16
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    i know right lol well its already on the car soo ill just make it work somehow i guess.

  17. #17
    Member damianj03's Avatar
    Join Date
    May 2009
    Location
    saint robert, mo
    Posts
    265

    slap your mama red
    1998 trans am

    i just plugged the hole in the lid with red silicone and flattend it off.

    the reason i went with red is because my lid is painted red

  18. #18
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    to cap mine off i went to home depot with my lid and found a chrome cap that fit and it looks nice imo

  19. #19
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    if your talking about the hole in the lid, the kit came with a plug for it. whats not hooked up is the hose that goes to the air pump..

  20. #20
    Member 98Hardtop's Avatar
    Join Date
    Jul 2009
    Location
    Richmond Va
    Posts
    180

    black
    1998 Camaro Z/28

    I have the same lid and as previously mentioned, it should have came with the extra tube and grommet for cars equipped with the air pump. You just need to hook it up.
    Last edited by 98Hardtop; 04-30-2010 at 10:36 AM.

    09 Vulcan 900 custom.
    2007 Subaru Legacy 2.5i
    1998 Z/28 Hardtop A4 | Y2K wheels | SLP Lid | Magnaflow catback |cutout | Hotchkis LCA'S/PHB | BMR TA and D/S Loop| Tuned by Frost....300rwhp/308rwtq

    97 Cobra- bolt ons | full exhaust| 4.30's| suspension | SCT tune- sold!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •