Results 1 to 4 of 4

SLP Header Install Problem

This is a discussion on SLP Header Install Problem within the External Engine forums, part of the LSx Technical Help Section category; Hey guys, I bought a used set of SLP longtubes that I'm installing. I've managed to get the driver side ...

  1. #1
    Member 00Z28DC's Avatar
    Join Date
    Aug 2007
    Location
    Cincinnati/Columbus
    Posts
    226

    White
    2000 Z28

    SLP Header Install Problem

    Hey guys, I bought a used set of SLP longtubes that I'm installing. I've managed to get the driver side in without too much trouble and have finished that side already. I'm having extreme difficulty getting the passenger sides in at all. The header is getting caught in three different spots. It looks like I might have to drop the K-member altogether to get it in. Keep in mind these are the "tuned" length headers. It's a stupid bend in the primaries that is catching on the K-member. I just wanted to see if anyone else had an issue like this or if anyone has any tips they'd like to give on getting this SOB in. And by tips I don't mean go buy different headers. Though I have considered it.

  2. #2
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Sell them and buy different headers, you will thank yourself later. Not only are they a pain to install, they will hang low and scrape on about anything. Not many people here have the SLP headers, so I don't see you getting much feedback from experience on your specific issue

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    yep, terrible header to use but that's neither here nor there. Did you pull the starter?

  4. #4
    Member 00Z28DC's Avatar
    Join Date
    Aug 2007
    Location
    Cincinnati/Columbus
    Posts
    226

    White
    2000 Z28

    Quote Originally Posted by Y2KPewterSS View Post
    Sell them and buy different headers, you will thank yourself later. Not only are they a pain to install, they will hang low and scrape on about anything. Not many people here have the SLP headers, so I don't see you getting much feedback from experience on your specific issue
    Yea I know a lot of people don't really care for SLP. As far as buying a new set of headers I don't have the money to do so unless I can manage to sell the ones that I have. I bought the headers with y-pipe and O2's for 300 if I remember correctly. As far as the clearance issue, I obviously won't know for sure until I drive it, but it seems like I have about as much clearance as I did before maybe a quarter inch less? I'm more worried about the 3" y-pipe being an issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SHorty Header Install Problem.....
    By jfl330 in forum External Engine
    Replies: 3
    Last Post: 07-13-2014, 06:48 PM
  2. Help: Header install problem!
    By Josh81990 in forum External Engine
    Replies: 16
    Last Post: 02-04-2010, 12:40 PM
  3. problem after header install
    By phantazn in forum External Engine
    Replies: 7
    Last Post: 11-06-2007, 05:53 PM
  4. problem after header install
    By rocksws6 in forum External Engine
    Replies: 10
    Last Post: 06-11-2007, 01:49 PM
  5. Big problem after header install.
    By yellowv in forum External Engine
    Replies: 5
    Last Post: 04-01-2007, 03:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •