Results 1 to 16 of 16

should it be backfiring?

This is a discussion on should it be backfiring? within the External Engine forums, part of the LSx Technical Help Section category; i got LT's and TSP Td's put on and it started out fine back fired once every couple times i ...

  1. #1
    2-Legit-2-Quit bgable's Avatar
    Join Date
    Jun 2007
    Location
    Cville,Indiana
    Posts
    772

    IBM
    2006 Pontiac GTO

    should it be backfiring?

    i got LT's and TSP Td's put on and it started out fine back fired once every couple times i drove it but now everytime after i get in it and then let off it back fires/sputters is this normal? am i leaking air or is it the tune i think i may be running rich?

  2. #2
    Member Speed Psychosis's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Age
    28
    Posts
    499

    Red
    98 T/A M6 w/lid and LM1

    probably just the tune. you should always get a tune after longtubes since your car will get screwed up in the fuel department. i thought that lts made you run lean though...

  3. #3
    2-Legit-2-Quit bgable's Avatar
    Join Date
    Jun 2007
    Location
    Cville,Indiana
    Posts
    772

    IBM
    2006 Pontiac GTO

    yah i need to get the tune finished but the guy is been away and is taking forever to finish it up...could driving it like this screw anyhing up?

  4. #4
    Member Speed Psychosis's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Age
    28
    Posts
    499

    Red
    98 T/A M6 w/lid and LM1

    from running rich? doubt it. but don't quote me on that. my friend has an rx8 and those cars run that rich stock. mazda did it to be safer since rotaries really need individual tunes since they are inconsistent in different climates etc.

  5. #5
    Pony Killer Insert's Avatar
    Join Date
    Apr 2008
    Location
    Mississauga, Ontario, Canada
    Age
    29
    Posts
    242

    Black
    2002 Camaro SS M6

    running rich shouldnt harm anything. but it isnt going to help your gas mileage

  6. #6
    rapter34
    Guest
    this was just my experiance last week. got my LT's on and all the exhaust in place than had the bolts back off and the gaskets that came with them really blew. so had the ticking and it was backfiring a hell of alot. got new gaskets and tightened them down now all better. Sounds sooooo good.

  7. #7
    2-Legit-2-Quit bgable's Avatar
    Join Date
    Jun 2007
    Location
    Cville,Indiana
    Posts
    772

    IBM
    2006 Pontiac GTO

    mine doesnt tick and i got new gaskets so i dont think thats the problem im pretty sure its just running rich...hopefully

  8. #8
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,692

    []D [] []V[] []D
    1999 trans am



    is it a back fire or exhaust pop???

    two different things..

    back fire = really loud boom and done... (rrrrrrrrrrrrrrrrrrrrrrBOOMrrrrrrrrrrrr)

    exhaust pop = several pops ( RRRRRRRRrrrrrrrrrrrrbaadbabadbbadbddababdbbdabdbba b)

  9. #9
    2-Legit-2-Quit bgable's Avatar
    Join Date
    Jun 2007
    Location
    Cville,Indiana
    Posts
    772

    IBM
    2006 Pontiac GTO

    exhaust pop
    Last edited by bgable; 06-13-2008 at 05:22 PM.

  10. #10
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Since I deleted air and egr mine now does this... btw...

  11. #11
    Member
    Join Date
    Nov 2007
    Location
    SATX
    Posts
    847

    Pewter
    2000 Trans Am

    Quote Originally Posted by Spaz View Post


    is it a back fire or exhaust pop???

    two different things..

    back fire = really loud boom and done... (rrrrrrrrrrrrrrrrrrrrrrBOOMrrrrrrrrrrrr)

    exhaust pop = several pops ( RRRRRRRRrrrrrrrrrrrrbaadbabadbbadbddababdbbdabdbba b)
    exaust pop is normal right?

  12. #12
    Member Speed Psychosis's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Age
    28
    Posts
    499

    Red
    98 T/A M6 w/lid and LM1

    Quote Originally Posted by Insert View Post
    running rich shouldnt harm anything. but it isnt going to help your gas mileage
    my car apparently was running rich. just spent $700 fixing it. Destroyed all o2 sensors and the cats are going bad too. I replaced the front o2s and the spark plugs and wires and it seems ok now (plugs were bad according to shop). I'd check your plugs before you get problems like i had...

  13. #13
    2-Legit-2-Quit bgable's Avatar
    Join Date
    Jun 2007
    Location
    Cville,Indiana
    Posts
    772

    IBM
    2006 Pontiac GTO

    plugs are brand new

  14. #14
    Senior Member grouch0jr's Avatar
    Join Date
    Nov 2007
    Location
    Philly, PA
    Age
    33
    Posts
    2,055

    Black
    2001 Firebird TransAm WS6

    as far as i know the popping is due to the exhaust being free-er flowing. suck back or something. i dont have LTs yet, but my cat back pops almost everytime i let off the gas, i think its awesome.

  15. #15
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by grouch0jr View Post
    my cat back pops almost everytime i let off the gas, i think its awesome.

    agreed

  16. #16
    Member Speed Psychosis's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Age
    28
    Posts
    499

    Red
    98 T/A M6 w/lid and LM1

    Quote Originally Posted by grouch0jr View Post
    as far as i know the popping is due to the exhaust being free-er flowing. suck back or something. i dont have LTs yet, but my cat back pops almost everytime i let off the gas, i think its awesome.
    yes, and also because its hot and the extra fuel that wasnt burned explodes, creating a pop. tuning it should get rid of this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. backfiring at low rpm
    By V8MUSCLE in forum General Help
    Replies: 28
    Last Post: 12-21-2010, 05:58 PM
  2. Backfiring???
    By paratrooper in forum External Engine
    Replies: 14
    Last Post: 10-15-2009, 09:36 PM
  3. backfiring(please help)
    By Boomer Sooner in forum General Help
    Replies: 6
    Last Post: 08-16-2008, 09:12 PM
  4. Backfiring!
    By Pappa Doo in forum Internal Engine
    Replies: 10
    Last Post: 09-06-2007, 08:50 PM
  5. backfiring
    By 94formulaLT1 in forum LT1
    Replies: 4
    Last Post: 03-15-2006, 08:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •