Results 1 to 11 of 11

SES/LS6 Intake Install

This is a discussion on SES/LS6 Intake Install within the External Engine forums, part of the LSx Technical Help Section category; Alright... So the last time it was my 'Check Gauges' light... Turns out I broke my OP Sensor (Shocker!) So ...

  1. #1
    Preferred Member CWW17's Avatar
    Join Date
    Apr 2006
    Location
    Central Illinois
    Age
    31
    Posts
    356

    Black | Black
    '07 Z06 | '98 WS6

    SES/LS6 Intake Install

    Alright... So the last time it was my 'Check Gauges' light... Turns out I broke my OP Sensor (Shocker!) So I took my LS6 Intake back out, got a new OP Sensor then reinstalled it. Now I start up the car and it runs and idles fine but my SES Light is on... What gives? It wasn't on the last time??? Anyone else get the SES Light after the Intake itstall?

    Yes, I kept my EGR System. And yes, I hooked everything back up!

    It is also worth mentioning that I ported and polished my throttle body as well as doing the bump stop mod...

  2. #2
    Preferred Member CWW17's Avatar
    Join Date
    Apr 2006
    Location
    Central Illinois
    Age
    31
    Posts
    356

    Black | Black
    '07 Z06 | '98 WS6

    anybody?

  3. #3
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    There's really no way to diagnose it without knowing what the code is.

    Go to your local Autozone or Advance Auto and have them pull the code, its free.

    Then we can pinpoint the problem and maybe help you out

  4. #4
    Awaiting Activation
    Join Date
    Mar 2006
    Location
    LS1 land
    Age
    29
    Posts
    1,667
    even with keeping the egr on the LS6 some ppl have thrown codes. As wesman said get the exact code.

  5. #5
    Preferred Member CWW17's Avatar
    Join Date
    Apr 2006
    Location
    Central Illinois
    Age
    31
    Posts
    356

    Black | Black
    '07 Z06 | '98 WS6

    Planned on doing that tomorrow, but thanks for the help!

  6. #6
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    Quote Originally Posted by Wesman View Post
    There's really no way to diagnose it without knowing what the code is.

    Go to your local Autozone or Advance Auto and have them pull the code, its free.

    Then we can pinpoint the problem and maybe help you out

    on my winter car the CHECK engine light has always been on can they also turn of any codes for free?

  7. #7
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by greatwhiteZ28 View Post
    on my winter car the CHECK engine light has always been on can they also turn of any codes for free?
    They can't turn codes off at all. Then can read them and erase them. If the problem isn't fixed though, the Check Engine Light will come right back on again.

    The car must also be 1996 or newer (OBDII) for them to pull/erase codes.

  8. #8
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    im out, 93 with 270,000 miles haaa i know, its on life support but beats driving the Z in the snow

  9. #9
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by greatwhiteZ28 View Post
    im out, 93 with 270,000 miles haaa i know, its on life support but beats driving the Z in the snow
    Can't argue that, thats what I have a beater for too
    1998 Trans Am WS6 SGM
    Lid, Pro 5.0, WS6 Short Stick, LS7 Clutch, TB Bypass, Detroit TrueTrac, Poly Mounts, Bilstein Shocks, LS6 Intake, SFCs, CTS-V Brake Upgrade, STB, Nitto 555's. SS Longtube Headers and True Duals w/ H pipe and Magnaflows. Tuned by Harris Speed Works. 341.4WHP/346.1 lb/ft.

  10. #10
    Preferred Member CWW17's Avatar
    Join Date
    Apr 2006
    Location
    Central Illinois
    Age
    31
    Posts
    356

    Black | Black
    '07 Z06 | '98 WS6

    problem solved but thanks for the input guys!

  11. #11
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    yea its a money pit, just put a compleate (whole ) brakes system on for like 650 dollars!!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: F.A.S.T Intake Install
    By Dr.Crash in forum External Engine
    Replies: 17
    Last Post: 02-05-2009, 04:28 PM
  2. Intake install
    By Wheeler99WS6 in forum External Engine
    Replies: 0
    Last Post: 04-09-2007, 05:38 PM
  3. what to a intake install
    By momsls1 in forum External Engine
    Replies: 4
    Last Post: 09-21-2006, 12:46 AM
  4. Need some help after Intake/Cam install
    By Barry00Z in forum External Engine
    Replies: 4
    Last Post: 07-23-2006, 07:46 PM
  5. ls6 intake ? INSTALL KIT
    By skar in forum General Help
    Replies: 3
    Last Post: 02-27-2006, 03:37 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •