Results 1 to 8 of 8

Service Engine Light...and check gages

This is a discussion on Service Engine Light...and check gages within the External Engine forums, part of the LSx Technical Help Section category; Alright I need some guidance...in more ways than one but we'll start with the first issue. I just purchased this ...

  1. #1
    Junior Member
    Join Date
    Mar 2009
    Location
    Meredith NH
    Posts
    28

    Navy Blue
    2001 Camaro SS

    Service Engine Light...and check gages

    Alright I need some guidance...in more ways than one but we'll start with the first issue. I just purchased this 01 SS the car has pacesetter LT headers, high flow cats and magnaflow exhaust. The 'service engine light' has been on since I picked up the car. I had a discussion with the previous owner and he told me that it was the headers 'f'ing' with the O2 sensors...which makes sense to me. What do I need to do to get this to go away and not comeback? I also had the 'check gages' light come on tonight...tonight is the first time I have driven the cat for more than a 1/2 mile. I did check my gauges and everything was fine...car was running perfect. Could this be related to the 'service engine light'?

    Please help....

    Thanks much,

    Scott


    01 CAMARO SS M6 NBM...Pacesetter LT, SLP Hiflows, Eibach Sportlines, Magnaflow catback, KN FIPK, SLP SFC's

    99 K3500 4x4 350fi - Flowmaster 50's -295/70/17 Terragrappler on Black H2 wheels

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Bring the car somewhere and have them read the code(s) to see why the SES is on and post'em. Places like autozone will read them free. Check gages may or may not be related - if they looked fine maybe the car was just low on fuel - it'll come on for that.

  3. #3
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by NHBighead View Post
    Alright I need some guidance...in more ways than one but we'll start with the first issue. I just purchased this 01 SS the car has pacesetter LT headers, high flow cats and magnaflow exhaust. The 'service engine light' has been on since I picked up the car. I had a discussion with the previous owner and he told me that it was the headers 'f'ing' with the O2 sensors...which makes sense to me. What do I need to do to get this to go away and not comeback? I also had the 'check gages' light come on tonight...tonight is the first time I have driven the cat for more than a 1/2 mile. I did check my gauges and everything was fine...car was running perfect. Could this be related to the 'service engine light'?

    Please help....

    Thanks much,

    Scott
    You might be able to have the engine light deleted, also this maybe dumb. But I have an 01 Camaro and when the fuel gauge get down to 1/8th of a tank my check gauges light comes on too. My gas gauge flots alot and triggers it. I dunno.
    Last edited by Smittro; 03-29-2009 at 06:52 AM.

  4. #4
    Junior Member
    Join Date
    Mar 2009
    Location
    Meredith NH
    Posts
    28

    Navy Blue
    2001 Camaro SS

    Thanks guys...I am a donkey because the car is low on fuel and I didn't realize that would trigger the 'check gages' light.

  5. #5
    GROUND KONTROL C.O. dneemorelos's Avatar
    Join Date
    Jan 2009
    Location
    Dallas, Texas
    Posts
    194

    PEWTER
    2002 Camaro Super Sport

    you can buy 02 sim's to cancel out the 02 sensor codes, or u can just tune them out completely.

  6. #6
    Junior Member
    Join Date
    Mar 2009
    Location
    Meredith NH
    Posts
    28

    Navy Blue
    2001 Camaro SS

    Thanks...I will do that...car runs awesome but I hate that light being 'on'

    Took it out for the first time last night and it hustles...

  7. #7
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    125 bucks for a tune from Frost.... Will solve all your issues except he wont pump more gas in your tank!

  8. #8
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: "Check Gages" light flickering on and off
    By pdiddyz28 in forum General Help
    Replies: 8
    Last Post: 08-06-2010, 04:06 PM
  2. Check Engine light vs. Service Engine light
    By bigrig73 in forum Computer & Tuning
    Replies: 1
    Last Post: 04-20-2010, 07:11 AM
  3. check gages light
    By mirmir200206@yahoo.c in forum New Member Introductions
    Replies: 4
    Last Post: 06-10-2008, 01:21 PM
  4. Service engine soon light = Check engine light?
    By jinxeng in forum General Help
    Replies: 5
    Last Post: 08-11-2006, 08:34 PM
  5. Check Gages Light...
    By cool87gn in forum General Help
    Replies: 4
    Last Post: 05-06-2006, 01:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •