Results 1 to 9 of 9

service engine light

This is a discussion on service engine light within the External Engine forums, part of the LSx Technical Help Section category; my service engine light came and they told me it threw out a code that my car is running lean. ...

  1. #1
    z28pwrHecz Z28pwrHecz's Avatar
    Join Date
    Feb 2006
    Location
    Mcallen, Tx
    Posts
    119

    Black
    2002 Chevy Z28

    service engine light

    my service engine light came and they told me it threw out a code that my car is running lean. would you guys know how to fix that problem?

  2. #2
    Awaiting Activation
    Join Date
    Mar 2006
    Location
    LS1 land
    Age
    29
    Posts
    1,667
    Quote Originally Posted by Z28pwrHecz View Post
    my service engine light came and they told me it threw out a code that my car is running lean. would you guys know how to fix that problem?
    how did you get it checked? What was the specific code #? Do you have any mods?

  3. #3
    MSG Crusty SPECOPS94's Avatar
    Join Date
    Mar 2006
    Location
    NC
    Posts
    153

    Limited Edition #1242
    2002 Camaro SS LE

    Could be a few things. The first thing I'd do is check the PCV hose. These are pretty bad about developing a slit in them which causes the ECM to run lean. The material used on the stock hose is extremely thin. GM has documented this. I had to take the LE in for service because of this and they simply replaced the hose and I've never had a problem since. The codes the ECM threw were P0171 and P0174, constantly, lean on both banks. Diagnositcs also showed several plugs misfiring at the same time, on the left bank only. Coils don't go out together like that!!

    The next thing could be the 02 sensors. But that depends on the codes.

    Mike

  4. #4
    z28pwrHecz Z28pwrHecz's Avatar
    Join Date
    Feb 2006
    Location
    Mcallen, Tx
    Posts
    119

    Black
    2002 Chevy Z28

    yeah the code it threw out was the P0171 on bank 1. i was reading and it said to clean the maf because of the oil on the filter. any idea how to clean the maf... or should i just take the car to the dealership? thanks i really appreciate all the help.
    -hector

  5. #5
    Awaiting Activation
    Join Date
    Mar 2006
    Location
    LS1 land
    Age
    29
    Posts
    1,667
    Quote Originally Posted by Z28pwrHecz View Post
    yeah the code it threw out was the P0171 on bank 1. i was reading and it said to clean the maf because of the oil on the filter. any idea how to clean the maf... or should i just take the car to the dealership? thanks i really appreciate all the help.
    -hector
    hahaha take it to the dealer. No they will charge you out the ass. I threw the same code last year and it was a dirty maf. Use electronic contact cleaner or similar. Radio shack has it. Just use the little stray with the can, and spray the little wires inside the MAF. Just be careful to not touch the wires- they are very fragile. Also, make sure that it is dry before you put it back on the car.

  6. #6
    z28pwrHecz Z28pwrHecz's Avatar
    Join Date
    Feb 2006
    Location
    Mcallen, Tx
    Posts
    119

    Black
    2002 Chevy Z28

    yeah i figured they would charge alot. thanks for the info. i will go to radio shack today and get myself some of that spray. thanks

  7. #7
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by Z28pwrHecz View Post
    yeah i figured they would charge alot. thanks for the info. i will go to radio shack today and get myself some of that spray. thanks
    See if you can go to your local auto parts store and get some of this stuff:



    Its the best for cleaning the MAF. They are very sensitive.

  8. #8
    z28pwrHecz Z28pwrHecz's Avatar
    Join Date
    Feb 2006
    Location
    Mcallen, Tx
    Posts
    119

    Black
    2002 Chevy Z28

    yesterday i got the maf cleaner and went ahead and sprayed it down. my service engine light didnt turn off. is it suppose to turn off on its own?

  9. #9
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Give it a few ignition cycles - or reset the PCM manually and see what happens. If it keeps coming back something else could be going on. www.gearchatter.com/viewtopic9369.php

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Service engine soon light ! why why why???
    By denegrader in forum General Help
    Replies: 35
    Last Post: 06-12-2011, 05:34 PM
  2. Check Engine light vs. Service Engine light
    By bigrig73 in forum Computer & Tuning
    Replies: 1
    Last Post: 04-20-2010, 07:11 AM
  3. Help: Service Engine Soon Light.engine Code No.7missfire
    By josh68 in forum General Help
    Replies: 10
    Last Post: 07-16-2008, 09:47 AM
  4. Service engine soon light = Check engine light?
    By jinxeng in forum General Help
    Replies: 5
    Last Post: 08-11-2006, 08:34 PM
  5. Replies: 14
    Last Post: 03-30-2006, 01:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •