Results 1 to 6 of 6

Secondary Air Injection

This is a discussion on Secondary Air Injection within the External Engine forums, part of the LSx Technical Help Section category; I've been having trouble with my AIR system. Car is a 2001 Trans Am Ws6 M6 . I live in ...

  1. #1
    Member FirehawkM6's Avatar
    Join Date
    Mar 2010
    Location
    Nor Cal
    Posts
    133

    Pewter
    2001 Trans Am Ws6 M6

    Secondary Air Injection

    I've been having trouble with my AIR system. Car is a 2001 Trans Am Ws6 M6 . I live in California so I need to smog it. I get a P0418 DTC all the time. I've replaced check valves, solenoid, relay, smog pump, and checked all hoses for leaks blockage etc. The car idles high when the solenoid doesn't turn on on cold start. When it does turn on the car idles fine. So after almost 3 months of this nightmare I've came to a conclusion. There is no power going to the solenoid or air pump. I powered the air pump with 12 volts and it works fine and its new. The solenoid sometimes works and when it does the car idles fine but the air pump never turns on so I get a DTC P0418 (secondary air injection relay A bank 1) . So where do I start? Where do I look for a bad ground or loose wire . Where do I start ??????????? Any help anyone !

    I have a new multimeter maybe it could help find a bad wire?
    2001 TRANS AM WS6 M6 . LS1. SLP LTs,SLP cats,SLP catback,SLP Lid,K&N filter, MSD Wires, AC Delco Iridium plugs, Redline Oils and Fluids, Ws6 Store Short Stick, Hotchkis strut tower brace

  2. #2
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Start by checking power at the relay. That'll tell you the direction you need to go. If you've got power at the relay, and then through the relay, you've got a break in the wiring going to the pump. Ensure that the plug connections are good as well.

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    The secondary air system should not impact how the engine idles. There is a hose connection over the driver side wheelhouse that you can easily pull apart and check for air blowing on cold startup. The system should only operate for about a minute or so and then turn off. Like Walt said, start by probing your relay for power. If you need schematics posted, let me know and I will gladly do so. Have you by chance unbolted anything from the back of the driver side head? If so, there are ground wires attached back there and it is possible that one is unhooked.

  4. #4
    Member FirehawkM6's Avatar
    Join Date
    Mar 2010
    Location
    Nor Cal
    Posts
    133

    Pewter
    2001 Trans Am Ws6 M6

    How do you check power to the relay? I'm not very savvy when it comes to this electrical stuff. And plug connections are good

  5. #5
    Member FirehawkM6's Avatar
    Join Date
    Mar 2010
    Location
    Nor Cal
    Posts
    133

    Pewter
    2001 Trans Am Ws6 M6

    Quote Originally Posted by pajeff02 View Post
    The secondary air system should not impact how the engine idles. There is a hose connection over the driver side wheelhouse that you can easily pull apart and check for air blowing on cold startup. The system should only operate for about a minute or so and then turn off. Like Walt said, start by probing your relay for power. If you need schematics posted, let me know and I will gladly do so. Have you by chance unbolted anything from the back of the driver side head? If so, there are ground wires attached back there and it is possible that one is unhooked.
    I would love some schematics. And I always check that hose on cold start up and I never get air blowing from it just air sometimes sucking from the hose connected to the diverter valve.

  6. #6
    Member FirehawkM6's Avatar
    Join Date
    Mar 2010
    Location
    Nor Cal
    Posts
    133

    Pewter
    2001 Trans Am Ws6 M6

    I did notice that the previous owner hooked up a manual fan switch that connected into a harness on the passenger side underneath the hood. I unplugged the harness and found a metal probe thingy to be full of green acid . I cleaned it and reconnected it and nothing

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What is the secondary air injection system
    By Street Fighter in forum General Help
    Replies: 13
    Last Post: 03-21-2015, 09:31 AM
  2. Help: secondary air injection
    By mvinson in forum General Help
    Replies: 4
    Last Post: 06-09-2012, 06:53 PM
  3. 99 trans am secondary air injection
    By MattB75 in forum External Engine
    Replies: 3
    Last Post: 01-27-2008, 08:29 PM
  4. Secondary Air Injection System DTC Code
    By Quicksilver Vert in forum Computer & Tuning
    Replies: 7
    Last Post: 09-03-2007, 06:35 PM
  5. Secondary Air injection codes popping up
    By blackTA6585 in forum General Help
    Replies: 12
    Last Post: 01-27-2007, 07:12 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •