Results 1 to 18 of 18

Radiator cracked, help replacing?

This is a discussion on Radiator cracked, help replacing? within the External Engine forums, part of the LSx Technical Help Section category; I got home today to see that coolant was spilling out of the car onto the ground and found that ...

  1. #1
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    Radiator cracked, help replacing?

    I got home today to see that coolant was spilling out of the car onto the ground and found that i had a leak in the top of my radiator. I have no idea how to replace, except to disconnect everything from it pull it and replace it.... i know its not that simple so can anyone else help me out as how to do it or should i let someone else do it?

    Its a 95 Camaro Z-28

  2. #2
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Well you can look at the cam install instructions at LS1 How to, I know yours is LT1 but should give you some idea what's goin on. Skip evrything cept the radiator removal. Lol.
    http://ls1howto.com/index.php?article=23

  3. #3
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    So i dont have to take the front end of the car off or anything like that?

    Oh yeah is there anything i should be careful not to do?
    Last edited by 95camaroZNC; 09-08-2008 at 04:46 PM.

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Don't get the opti wet. Thats bad JuJu. no The front clip doesn't have to come off. Dissconect the battery. Drain the system, remove and hoses and sensors attached to the rad, remove the air box, unplug the fans, unbolt and remove the upper support and voila. Thats the shot version of it but thems the basics.

  5. #5
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    So the link you all sent me pretty much covers everything, Wish me luck im going to try friday when they get the radiator in.

  6. #6
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    You all suck, this was kinda difficult. I did part of it and ........ ok i guess it wasnt that hard if id known and done it before. Anyway how do i get the hoses off in a easy way, the clamps are difficult to get off.....
    Last edited by 95camaroZNC; 09-09-2008 at 03:34 PM.

  7. #7
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    H good pair of plyers if they are a spring clap, You would ahveto wiggle them and trust them a bit. Same if they are a hose clamp type. The hoses, well get a flat blade screwdriver under there and try. They will be stuck and need some force to get free.

    This would be a good time to replace em if they are old, So you could cut and peel them as well.

  8. #8
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    I was kidding...... about the sucking.... i mean if you cant contribute anything why do that.

    Anyway thanks for the advice on the clamps thats the only thing ive had a problem with so far, when i do get done ill try and do a write up for a LT1 radiator since im doing it for my car club forum.

    Is there anything else i need to know, oh yeah and will the condenser sit up in the front where it is or do i need to take it out too? It looks like it just detaches from the radiator and lifts up and out of the slots in it. Anyway thanks for the help so far im gona try and finish up friday since i have the day off work. The most annoying thing so far has been that the idiot who had it before me put the bolt for it upside down....

    Anyway you guys and thanks for the help so far.

  9. #9
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    The condenser should just sit there if you are careful with it. Shouldn't need to remove it, but I have yet to remove a rad on one of those cars.

  10. #10
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    Oh yeah, is there anything that can go wrong sensor wise in the car from unplugging all the stuff that was in the air intake?

  11. #11
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    As long as you are careful, There shouldn't be. Make sure the battery is disconnected. Be sure that they all get fully connected when it all goes together.

  12. #12
    MANWHORE TEAM suede's Avatar
    Join Date
    Apr 2007
    Location
    Your Mom's Bedroom
    Posts
    4,548

    Negro
    2000 Trans Am WS.6

    melt a zip tie on where its leaking from with a torch, Its what we did with our race car...

  13. #13
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    Soo i got in all installed and now the cars over heating, i purged all the air out of the lines and have figured out its because the Fans arent running at all, the fans worked fine before but now they are not. Also with all the stuff i removed from the old radiator i also removed a small green box and out it on the new radiator, my friend removed it rather harshly and everything ive read makes no mention of it, not even the haynes manual i broke down and bought today.

    I welcome any suggestions you all have, id really like to get the car fixed as fast as i possibly can, i know i didnt mess up the thermastat as well becasue it says that if the top pipe is hot then its circulating the water, which it is, I really think its just the fan.

    I tryed to figure it out for 8 hrs today and no luck....... im about to and have someone else fix it but i really want to finish it myself.

  14. #14
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    You would know right quick if the fans were working or not. Backtrace your steps starting at the fans and working backwards. Make sure everything is plugged in correctly and is nice and tight. The connection can look like they are plugged in but not be fully seated.

  15. #15
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Wrote ya on fayetteville...
    J
    2001 SS, Its not the car its the Driver that matters....

  16. #16
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    They are connected. I double checked the connectors.

    The fans did work before i started the project, We just tryed what you said and the fans ran while the car was sitting still with the AC one of them was running really strong and one of them felt kind of weak. My dad had me turn the AC off and drive it around a few times, sure enough the car started to over heat again, when we parked the car we tryed turning the AC back on to see if the fans would kick on, they didnt come back on when i turned the AC back on. Any ideas?

    We have decided what ever part is responsible for turning the fans on and off, ISNT turning the fans on and off.....
    Last edited by 95camaroZNC; 09-13-2008 at 04:44 PM.

  17. #17
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Try swaping out the relay.

  18. #18
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    I gave up and took it to my mechanic ill be sure to post what the problem is when he figures it out, he looked at it today and couldnt figure it out so i guess i dont feel so bad about it. Thanks for all your help though guys i really cant thank you enough!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Boiling sound at radiator, radiator cap blowin off
    By lanprat in forum External Engine
    Replies: 7
    Last Post: 08-05-2012, 05:29 PM
  2. Question: Cracked Radiator... any non plastic replacement suggestions?
    By manibot in forum External Engine
    Replies: 2
    Last Post: 08-26-2011, 07:27 PM
  3. Radiator cracked
    By zeetwentyeight in forum General Help
    Replies: 8
    Last Post: 11-19-2009, 04:14 PM
  4. Help - cracked radiator
    By MSTZ TA in forum External Engine
    Replies: 22
    Last Post: 07-13-2009, 04:47 PM
  5. Replies: 0
    Last Post: 04-03-2007, 10:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •