Results 1 to 11 of 11

power steering woes!!!!!!

This is a discussion on power steering woes!!!!!! within the External Engine forums, part of the LSx Technical Help Section category; 99 Z28 with 58k on it. Power steering started making noise. Did a flush and it still made noise. Replaced ...

  1. #1
    Junior Member 99Redz28convt's Avatar
    Join Date
    Apr 2006
    Location
    Erie, PA
    Posts
    22

    RED
    99 Z28 CONVERTIBLE 6M

    Unhappy power steering woes!!!!!!

    99 Z28 with 58k on it. Power steering started making noise. Did a flush and it still made noise. Replaced the pump. Still made noise. Fluid white and thick. Replaced the high pressure line thinking there might be a small pinhole. Still noise. Did cooling system pressure test to check for bubbles in the power steering -- no bubbles. Bled the power steering system... no air in the system. Flushed fluid again. Now more noise than EVER! Yes I'm using power steering fluid (not trans). I'm a service manager at a car dealership and I have tons of resources.... but I'm stumped. The only part left to my knowledge is the rack. Help!

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    by pass the cooler in the lower rad hose. they are known to crack. Fush the power steering system really well to remove any contaminates and replace the pump again.

    What kind of noise is it making?

  3. #3
    Junior Member 99Redz28convt's Avatar
    Join Date
    Apr 2006
    Location
    Erie, PA
    Posts
    22

    RED
    99 Z28 CONVERTIBLE 6M

    you mean the cooler in the upper hose? Its making a whining noise from the pump. More noise when you turn. More noise when its hot than whe its cold... The pump is 2 weeks old....

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    yea, that one, looks like a lenght of aluminium pipe with a flange in the middle bolting it all together. Only two things will make noise the pump or the rack, so I guess the rack wouldbe the next step in the process.

  5. #5
    Junior Member 99Redz28convt's Avatar
    Join Date
    Apr 2006
    Location
    Erie, PA
    Posts
    22

    RED
    99 Z28 CONVERTIBLE 6M

    Yeah, that was what I was afraid of. Some people I talked to suspected a blockage in the rack preventing fluid to flow. I think the flush (this time) may have dislodged some debris... I'd love another alternative...

  6. #6
    Member
    Join Date
    Jun 2009
    Location
    coon rapids, MN
    Age
    52
    Posts
    404

    red
    2000TA

    if you are handy remove the rack find or make a tool to remove the ends and replace the 25 cent O-rings.or use gear lube alot to recondition the seals.

  7. #7
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    maybe you got a bad pump

  8. #8
    Member 02fbody35th's Avatar
    Join Date
    Feb 2008
    Location
    scranton,pa
    Age
    31
    Posts
    279

    red
    2002 camaro 35th anv.

    it is possible you got a bad pump, especially if it is a reman. I went through three pumps before i finally got one that didnt whine.

  9. #9
    Member raysz28's Avatar
    Join Date
    Sep 2005
    Location
    Central Ohio
    Posts
    180

    Ticket Red
    M6 1998 Z-28

    hopefully this is a dumb question for you...did you make sure to tighten the PS pulley all the way back on? the belt will make a lot of noise if that pulley is causing the belt to not be straight.

    98 Ticket Red Z28
    Mods:
    Front/rear sway bars, poly bushings all around, Bilstein Shocks, Centerforce Dual Friction Clutch, Pacesetter LT's, 2.5" Custom True Duals over the axle with Magnaflow mufflers, Shortened Pro 5.0 shifter, TurnOne PS pump.

  10. #10
    Junior Member 99Redz28convt's Avatar
    Join Date
    Apr 2006
    Location
    Erie, PA
    Posts
    22

    RED
    99 Z28 CONVERTIBLE 6M

    Good point about the reman pump.....and yes I used the correct special tool to remove and install the pulley. Definitely pump noise not belt noise.

  11. #11
    Member raysz28's Avatar
    Join Date
    Sep 2005
    Location
    Central Ohio
    Posts
    180

    Ticket Red
    M6 1998 Z-28

    I went through a re-manufactured pump also. save yourself a lot of trouble and future worry and get a TurnOne Pump...its well worth the extra dough in performance and reliability. http://www.turnone-steering.com/pumpdirectory.html

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. power steering
    By 99maroz28 in forum External Engine
    Replies: 3
    Last Post: 11-12-2011, 02:01 PM
  2. Question: Power Steering, Manual Rack, Power Steering Pumps-etc
    By TerribleTed in forum General Help
    Replies: 2
    Last Post: 11-18-2010, 05:37 PM
  3. power steering
    By 99ss in forum General Help
    Replies: 9
    Last Post: 05-29-2010, 01:57 PM
  4. Power steering
    By Pony_Eater in forum Parts Wanted / Trade
    Replies: 3
    Last Post: 06-12-2009, 02:42 PM
  5. power steering help
    By camarostripes96 in forum External Engine
    Replies: 5
    Last Post: 06-07-2007, 03:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •