Results 1 to 12 of 12

power steering pump question

This is a discussion on power steering pump question within the External Engine forums, part of the LSx Technical Help Section category; i have 141K on original, and it is starting to pulsate while driving and turning. it also started making the ...

  1. #1
    Junior Member oharam's Avatar
    Join Date
    Feb 2011
    Location
    Tampa Bay
    Posts
    83

    Black
    1999 Z-28 LS1

    power steering pump question

    i have 141K on original, and it is starting to pulsate while driving and turning. it also started making the typical whine, my question is, is it worth to try and rebuild it, or nust get a new pump without the resevoir? i want to keep cost down, so when i go for the entire engine build i can put everything new.

    thanks guys!

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Have you ever replaced the fluid?

  3. #3
    Junior Member oharam's Avatar
    Join Date
    Feb 2011
    Location
    Tampa Bay
    Posts
    83

    Black
    1999 Z-28 LS1

    I have not replaced the fluid, just topped it off when needed. I did notice that it was about half full this morning, which is lower than it was about a month ago. I have not noticed any fluid on my garage floor. what is the easiest way to change the fluid?

    thanks!

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Is your car equipped with a power steering cooler in the upper radiator hose?

  5. #5
    Senior Member Danger731's Avatar
    Join Date
    Aug 2000
    Location
    Indy
    Posts
    6,712
    ^ I don't know if 99's had PSC's. I am planning on bypassing mine for the winter then installing a better one up front. As for the orininal poster:

    Try switchin out the fluid, suction out, fill, go lock to lock, suction out, fill... do that several times till it looks ok, usually 4 to 5 times. If it is still an issue it may be the pump, or it may be getting air. Stop the car and look to see if it is boiling next time. If it isn't boiling then it may be fluid or the pump. These PS systems are a pita. I'm on my 4th. I would just replace the pump, the resevoir should be fine. The pulley is a pita.
    04 C5 A4 Torch Red

    2009 CTS4 Ice Black

    2013 1500 Silverado Z71

    02 Z/28 M6 Onyx Black All Options - Sold

  6. #6
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    id try swapping out the fluid and if it still continues to whine just replace it..

  7. #7
    She Moderator KahanaReef's Avatar
    Join Date
    Jul 2008
    Location
    So Cal
    Age
    54
    Posts
    15,589

    Arctic White
    2000 Camaro Z28

    When I bought my car, I was having a similar issue. I took it down and my mechanic, mechanically flushed it. He said it was so dirty, he had to do it twice. It's been great ever since. No more issues. That was over 3 years ago

  8. #8
    Junior Member oharam's Avatar
    Join Date
    Feb 2011
    Location
    Tampa Bay
    Posts
    83

    Black
    1999 Z-28 LS1

    I'm going to try the fluid change out tomorrow, and see how it handles after that.

    thanks for the help guys!

  9. #9
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    If you havent changed it in awhile try to change it out a few times to get rid of the bad fluid completely

  10. #10
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    I use a turkey baster to suction out fluids all the time. It drips a bit, but otherwise works perfect for things like the power steering reservoir, brake fluid and such.

  11. #11
    Junior Member oharam's Avatar
    Join Date
    Feb 2011
    Location
    Tampa Bay
    Posts
    83

    Black
    1999 Z-28 LS1

    i did use the turkey baster and had to do the power steering res 3 time, and will do it again in a week or two. i re did the brake master cylinder and that is looking good. i did realize when i filled it up yesterday (PS pump) that i filled it to much and when it built up pressure it pushed thru the cap seal. took it for a ride tonight and it looks like its doing better, i dont have that shimmy in the steering now.

    again, thanks for the help everyone!

  12. #12
    Senior Member Danger731's Avatar
    Join Date
    Aug 2000
    Location
    Indy
    Posts
    6,712

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: power steering pump
    By 98LS6SSCAMARO in forum General Help
    Replies: 2
    Last Post: 03-04-2013, 07:29 AM
  2. Question: Replaced Power Steering Pump-Bleeding Question
    By Boat in forum General Help
    Replies: 9
    Last Post: 06-05-2008, 05:51 PM
  3. Power Steering pump leak?! new pump or seal kit?
    By JehalinTA in forum General Help
    Replies: 2
    Last Post: 03-18-2008, 11:05 PM
  4. Power steering pump
    By earsti in forum Internal Engine
    Replies: 2
    Last Post: 07-09-2007, 04:55 PM
  5. power steering pump
    By roadrashr6 in forum General Help
    Replies: 1
    Last Post: 01-01-2006, 08:15 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •