Results 1 to 4 of 4

Please Help Tb Issues

This is a discussion on Please Help Tb Issues within the External Engine forums, part of the LSx Technical Help Section category; I have recently bought a FAST MANIFOLD and TB. The TB was very sticky and I got a lot of ...

  1. #1
    Junior Member
    Join Date
    Nov 2006
    Location
    Apopka Fl
    Posts
    4

    Pewter
    02 TRANS AM

    Angry Please Help Tb Issues

    I have recently bought a FAST MANIFOLD and TB. The TB was very sticky and I got a lot of info that Fast TB are known for that so I returned it and got a NICK WILLIAMS TB the tech service for RPM SPEED said they have never had a return on the Nick Williams. I recieved the TB and had the same issue if I accelerate slowly it sticks at the RPM's i rev it to. I need help on what to do I am about to return this TB and recieve another NICK WILLIAMS cause im lost. PLEASE if you have had this issues please help me. I have not drivin my baby in almost 2 months boohoo.

    P.S 2002 WS6 TRANS AM 30,000 MILES pushing a little over 400hp to the wheels

  2. #2
    Junior Member ace's Avatar
    Join Date
    Jul 2006
    Location
    kyle tx.
    Age
    49
    Posts
    71

    pewter
    99 camaro ss

    I was having the same problem with my BBK last week!!! I just adjusted the screw and opened up the TB alittle just before the idle started going up. I was ready to throw the dam thing away. But that took care of my problem.And mine only did it when the car was on!!If the car was off the TB did not stick.Hopefully that is your problem to.

  3. #3
    Junior Member
    Join Date
    Nov 2006
    Location
    Apopka Fl
    Posts
    4

    Pewter
    02 TRANS AM

    I found out the hard way that mine stuck when car was of when trying some stuff it got to 5000rpm so I turned the car off and hit the throttle 2 or 3 time to give it back pressure to close then turned the car on, went straight to red line max a little smoke came out and also a tear from me. my LS1 guy said do a BBK that thats the best but if you had the same issue? and my manifold only fits a 90mm also.

  4. #4
    Master Mechanic Jims455's Avatar
    Join Date
    Jun 2006
    Location
    Crowley Texas
    Posts
    212

    Red
    '02 WS6

    90mm TB? Do you ported heads, big cam and headers to move all that air?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. tv issues
    By 2000redcamaro in forum Almost Anything Goes
    Replies: 15
    Last Post: 12-24-2009, 10:47 AM
  2. Q-Jet Issues?
    By pajeff02 in forum Classic Muscle
    Replies: 7
    Last Post: 09-07-2009, 01:31 PM
  3. will 20's fit on gto with no issues
    By johnjr45 in forum GTO
    Replies: 4
    Last Post: 08-11-2007, 05:48 PM
  4. PM Issues
    By schtick in forum Request and Feedback
    Replies: 0
    Last Post: 07-10-2007, 06:54 PM
  5. Having some serious issues.
    By Banshee1967 in forum Suspension and Handling
    Replies: 2
    Last Post: 03-31-2007, 08:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •