Page 1 of 2 12 LastLast
Results 1 to 20 of 38

pacesetters LT's

This is a discussion on pacesetters LT's within the External Engine forums, part of the LSx Technical Help Section category; is installing these pacesetters really that hard or is it hype??? tricks ????...

  1. #1
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    pacesetters LT's

    is installing these pacesetters really that hard or is it hype??? tricks ????
    If you have the means and the desire, be prepared to do whatever it takes.

    so far:
    suncoast creations functional ram air setup,pacesetter LT's/ORY,magnaflow,pro 5.0,hurst stick,LS6 cam,4:10 gears/stock rear(screaming for mercy!!!)
    -still more to come!!!!!!

  2. #2
    Senior Member Street Lethal's Avatar
    Join Date
    Aug 2005
    Location
    Old Bridge "Raceway Park" N.J.
    Posts
    1,249
    2009 Corvette ZO6

    Isn't too hard at all. A lift makes it much much easier, though....

  3. #3
    Senior Member Rhinohuey's Avatar
    Join Date
    Mar 2007
    Location
    Glendale, AZ
    Posts
    1,460

    Black
    1999 Trans Am

    Me and a friend of mine did it in about 6 hours. It was the biggest project either of us had done at that point. We just used ramps, stands, and we had 2 jacks. Really, the hardest part is just getting the car high enough in the air to slide the headers in. Everything is cake from there.

  4. #4
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    got a lift at the shop so itll be easier i hope. thanks!!!

  5. #5
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    i would recomend using a can of rust penetrans and giving everything a once over the night before tearing it apart, you will save your self a lot of busted knuckles and broken bolts;.

  6. #6
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    do you actually need to unbolt the mounts or can you do it w/ them in place??

  7. #7
    STAY PUFT thecorrectformula's Avatar
    Join Date
    Jun 2007
    Location
    Delaware, OH
    Age
    30
    Posts
    678

    Navy Blue Metallic
    98 Formula

    My brother in Law did a set in three Hours with a lift

  8. #8
    Junior Member
    Join Date
    Aug 2006
    Location
    maryland
    Posts
    71

    yellow
    2002 trans am

    I Just did my pacesetters last week. Peice of cake. U dont have to un bolt the motor mounts. I didn't have to even unbolt the sterring shaft or cut nothing they slide right in. But a good thing to do is get some penitrating oil I used PB and give all the bolts a good shot the night befor then shootum again about a hour before. I did mine by myself in my garage on jackstands in about 8 hours. Make sure u get the car up as high as u can.

  9. #9
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    thanks for the help guys. Monday is d-day!

  10. #10
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    ive installed hookers and a pacesetter y pipe, the hooker headers were a nightmare, took all night until noon the next day, had to unbolt secondary air, steering shaft, reciever drier, and a few other things cant really remember!

  11. #11
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    they're in!!! a bit of a P.I.A. but done! the d/s mount did have to be unbolted to slide it in. but all is together now. now working on this sputtering issue.....

  12. #12
    Member Hot Rod SS's Avatar
    Join Date
    Sep 2006
    Location
    South Carolina
    Age
    39
    Posts
    61

    Pewter
    2000 Camaro SS M6 #3,850

    I'm about to install a Magnaflow cat back system this Friday, and plan to do Pacesetter longtubes and an ORY later, keep us posted on the sputtering thing.

  13. #13
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    still trying to figure it out!!!

  14. #14
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    the sputtering issue, when does it do it? cold hot? idle off idle?
    let me know i can see if i can help you any!

  15. #15
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    sputters any time im under 2k rpm or heavy acceleration. at first i saw the dipstick tube touching one of the boots. fixed that. no difference. noticed the gasket for the egr pipe that goes into the intake was leaking. gonna fix that this afternoon.


    p.s. i scanned the codes. only O2 codes came up. the car is running extremely rich. at a stop it makes your eyes water. could that be doing it????

  16. #16
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    update

    replaceing the egr gasket seemed to help eliminate the low end sputtering but i still breaks up after 4k. possible o2 issues? could O2 cheaters help and where could i get them? and if any is from NY do you know of a tuner in the Long island area???

    thanks a lot guys!!
    andrew

  17. #17
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    do you have any type of scanner or acess to look at live vehicle data? this would help! but i would say that if you still have the o2's in with the headers and no cats, this could fool the pcm real bad, not only that but i have seen bad exhaust leaks cause a rich mixture as well make sure your not sucking in air, and check for leaks at the head!

    and no i dont know of any tuners out there i am from so cal!

  18. #18
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    checked for exhaust leaks already. all is good. i dont have diagnostic tools but a cousin runs a shop. he can get me in on monday.

    someone told me that the "o2 cheaters" just plug into the existing wiring and fool the pcm into thinking everything is good. is that how they work?


    p.s. picked up set of wires from local performance chevy dealer. all rubber boot. ill put them in and see if that'll help.

  19. #19
    Driving like i stole it!! dafizzman1's Avatar
    Join Date
    Oct 2005
    Location
    Centereach, NY
    Age
    31
    Posts
    184

    Arctic White
    1998 Formula

    maybe a lead... when i took the wire off the second in on p/s (cylinder 4??) the car ran the same. is it possible that a coil could go bad in the 6+ hours you have it disconnected.

  20. #20
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Quote Originally Posted by dafizzman1 View Post
    maybe a lead... when i took the wire off the second in on p/s (cylinder 4??) the car ran the same. is it possible that a coil could go bad in the 6+ hours you have it disconnected.
    Sounds like you found the misfire. Make sure you put the plug wire back on both sides all the way.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pacesetters or slp
    By mr_r0bert0 in forum External Engine
    Replies: 32
    Last Post: 10-28-2008, 05:24 AM
  2. pacesetters on a 99 t/a
    By via sin dios in forum External Engine
    Replies: 1
    Last Post: 07-13-2007, 08:44 AM
  3. Pacesetters LT
    By 0235thannviSS in forum External Engine
    Replies: 4
    Last Post: 04-08-2007, 01:44 PM
  4. Pacesetters
    By OnEbAdReDSS in forum External Engine
    Replies: 22
    Last Post: 02-05-2007, 12:13 AM
  5. Pacesetters on the way
    By Huskerz1 in forum External Engine
    Replies: 14
    Last Post: 01-16-2007, 10:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •