Results 1 to 14 of 14
Like Tree2Likes
  • 1 Post By pajeff02
  • 1 Post By pajeff02

oxygen sensor simulator help

This is a discussion on oxygen sensor simulator help within the External Engine forums, part of the LSx Technical Help Section category; hey guys I haven't been on here in a while but am in need of some help with my 99' ...

  1. #1
    Member Ghawk996's Avatar
    Join Date
    Jun 2008
    Location
    Knoxville
    Posts
    198

    Black
    1998 Trans Am

    oxygen sensor simulator help

    hey guys I haven't been on here in a while but am in need of some help with my 99' Chevy Blazer.

    The problem is that someone cut off my catalytic converter so now I was wondering if anyone knows where I can get a direct plug in o2 simulator or do I just need to buy an aftermarket Catalytic converter from Summit Racing. Plus money is kinda tight at the moment.

    Thanks

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Just ignore the check engine light and keep driving it. That is your cheapest and easiest fix.
    Smittro likes this.

  3. #3
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Yup, Jeff is correct. It will not harm your engine at all to drive the car without a catalytic converter. Now, if you have to get emissions in your state then you'll need to get the code cleared. Replacing the cat, getting an O2 simulator, or getting a Frost tune to remove it would be your options for that. Just a FYI, the 02 simulators are prone to be problematic.

  4. #4
    Member Ghawk996's Avatar
    Join Date
    Jun 2008
    Location
    Knoxville
    Posts
    198

    Black
    1998 Trans Am

    Well without the cat the o2 sensor is not working correctly and the Blazer is running very poorly and burning the fuel.

  5. #5
    Member SuperSSguy's Avatar
    Join Date
    Jul 2012
    Location
    NorCal
    Posts
    979

    Sunset Orange Metallic
    2002 Camaro SS M6

    OP are you talking about the rear 02`s? cause that shouldnt effect the way it runs.

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by Ghawk996 View Post
    Well without the cat the o2 sensor is not working correctly and the Blazer is running very poorly and burning the fuel.

    Ummm. No. The lack of a converter is not adversely affecting the OP's engine. The rear O2 senders have absolutely nothing to do with fueling. All they do is report back to the PCM and tell it if the converters are functioning properly.

  7. #7
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Not having a cat or a funtioning rear 02 sensor will in no way effect the way a 4.3L v6 consumes fuel or operates.

    Time to start searching for other issues.

  8. #8
    Member Ghawk996's Avatar
    Join Date
    Jun 2008
    Location
    Knoxville
    Posts
    198

    Black
    1998 Trans Am

    Well I guess that I need to check this further because it is over fueling and not running at full power. The motor was running strong prior to an engine swap from another blazer and while I was doing this someone cut the Catalytic converter off along with the pipe and sensor. I guess I will need to check the timing.

    Any suggestions on why it is running really rich with a strong gas smell.

  9. #9
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Are you running a custom tune from the prior engine setup? Is it the same MAF?

  10. #10
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    So this is a junk yard motor? If so I'd have a hard look at the front 02 and wires for damage.
    Are you using the salvage engine wire harness? Is the service engine light flashing?

  11. #11
    Member Ghawk996's Avatar
    Join Date
    Jun 2008
    Location
    Knoxville
    Posts
    198

    Black
    1998 Trans Am

    The motor is out of another blazer my sister wrecked which was running strong. I bought another blazer which had a blown engine. So I just figured that it was the sensor since it was missing. I am open to suggestions tho.

  12. #12
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Do you have access to a scanner that will show your fuel trims?

  13. #13
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Ok, so it is a salvaged engine. It's very important you answer the questions we ask if you want us to be able to help you.

    Again,, is the service engine light flashing?

    Did you change the wire harness in any way, whether from one engine to the other, or make any repaires such as splices etc?

    Are the blazers from the same year or are they different?

    Did you exchange the PCM from one to the other?

    Did you hook everything up (aside from the rear o2 sensor) without leaving anything disconnected?

  14. #14
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Agree. Sounds like there is more going on here than just a simple sensor issue.
    Smittro likes this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. more oxygen sensor help
    By 2002 in forum General Help
    Replies: 8
    Last Post: 08-21-2016, 07:17 PM
  2. Question: Walker oxygen sensor (has anyone used these)
    By allbaugh_04 in forum General Help
    Replies: 10
    Last Post: 11-12-2009, 08:23 PM
  3. Oxygen Sensor
    By NJ2002WS.6 in forum General Help
    Replies: 9
    Last Post: 09-04-2008, 05:09 PM
  4. o2 solenoid oxygen sensor
    By feras in forum External Engine
    Replies: 2
    Last Post: 04-19-2007, 03:50 AM
  5. 97 Chevy Z71 O2 sensor simulator
    By stelmadl in forum GM Trucks
    Replies: 0
    Last Post: 10-04-2005, 06:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •