Results 1 to 4 of 4

O2 simulator problem

This is a discussion on O2 simulator problem within the External Engine forums, part of the LSx Technical Help Section category; Hey guys maybe you can shead some light on my problem. I have a 98 Z28. My check engine light ...

  1. #1
    Junior Member
    Join Date
    Dec 2005
    Orlando FL

    98 Z28 Camaro

    O2 simulator problem

    Hey guys maybe you can shead some light on my problem. I have a 98 Z28. My check engine light came on three days ago. I scaned the code and it came up as P0135 (Oxygen sensor heater circuit malfunction pre-converter sensor, left bank). I have long tube headers with the off road Y-pipe. I have Casper o2 simulators. I also had the car tuned a year ago and the guy that tuned it said he deleted the o2 sensor codes so I dont even need simulators but I left them on anyways. I've had this set up for about a year now and never had a check engine light. I checked all the wires and they look intacted and pulled the o2 sensors wiped a little carbon build up off them but not much. The o2 simulators have these red lights on them that blink off and on when the car is on, not sure if thats normal or what. Any info is much appreciated. Thanks

  2. #2
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    orlando, fl

    dark bowling green
    2000 corvette

    the code tells you it's the driver's side front o2. not a rear o2 issue.

  3. #3
    # 1846 mahoney1's Avatar
    Join Date
    Jan 2006
    Malden Ma.

    CETA Yellow
    2002 WS6 CETA

    You have 02 sims in place of the downstream 02's (after cat). If you code is bank1 sensor1 then its pre cat and has nothing to do with your sims. Also a heater circuit code doesnt mean that your 02 is not sensing the oxygen level properly, but that its not heating up fast enuff. The computer sends a current to the sensor to warm it up so your car gets out of closed loop faster, and you dont waste as much gas.

  4. #4
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Bragg NC

    Met. Sunset Orange
    01 SS

    Yepp yepp pre-cat sensor, nothing too do with the sims, I would swap 02's and see if the code changes or follows too the other side, Or just replace. Check your 02 wires too make sure none of them are burnt or melted.
    2001 SS, Its not the car its the Driver that matters....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts