Results 1 to 6 of 6

o2 sensor question

This is a discussion on o2 sensor question within the External Engine forums, part of the LSx Technical Help Section category; just before i parked my car for the winter, i got a SES code that both of my o2 sensors ...

  1. #1
    Don't Listen to Me NE98LS1's Avatar
    Join Date
    Dec 2005
    Location
    Nebraska
    Age
    34
    Posts
    1,469

    White
    1998 Trans Am

    o2 sensor question

    just before i parked my car for the winter, i got a SES code that both of my o2 sensors are bad. i am planning on putting headers on this spring, and i know that with certain years of LS1s you need to put in a simulator to fool the second sensor. my car is a 98 and i will be putting on pacesetter LT's with the pacesetter ORY. what should i do about new sensors? how much do these run?

  2. #2
    Pathelogical Liar BlackLT1Z28's Avatar
    Join Date
    Aug 2006
    Location
    Missouri
    Age
    30
    Posts
    1,476

    Black
    94 Camaro Z28

    One of my O2's were stuck in the manifold, so I bought a new one off of e-bay. It was only $50 or so. I called the dealership and asked how much, and they wanted ~$90. So, check e-bay.

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Too be honest if your gonna but lt's and ory then what i would do is wait too replace the sensors, pick up two 02 sims for where the rear 02 sensors plugged in. Then take the sensors from the rear and move them up front and it should work fine. I pick up my sims for 80 bucks im thinkin. Check out one of our sponsers. Also make sure you get 02 extensions for the front two sensors. 24" in length.
    J
    2001 SS, Its not the car its the Driver that matters....

  4. #4
    Don't Listen to Me NE98LS1's Avatar
    Join Date
    Dec 2005
    Location
    Nebraska
    Age
    34
    Posts
    1,469

    White
    1998 Trans Am

    yeah, i get the extensions in my package deal. that is kinda what i was thinking (new for the front, simulators for the rear) however i didn't know they were in pairs, i thought there was just one for the back, and one for the front.

  5. #5
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    No you should have two 02 sensors pre cat "befor each of your cats" and you should have two post cat "after the cat". The sims should eliminate the rear two sensors. Then you can move the ones that were in the rear to the front so you dont have too purchase new 02 sensors, i know there not cheap lol.
    Your call thou you can either go new up front or try the used ones.
    J

  6. #6
    Don't Listen to Me NE98LS1's Avatar
    Join Date
    Dec 2005
    Location
    Nebraska
    Age
    34
    Posts
    1,469

    White
    1998 Trans Am

    sounds good i'll see when i get these damn christmas CC bills paid off and enough money to buy my headers but it's gotta be done before i get it out again in the spring! thanks again

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. o2 sensor question
    By Justin23454 in forum External Engine
    Replies: 8
    Last Post: 01-20-2012, 10:29 AM
  2. Cam Sensor Question
    By henrysangret in forum External Engine
    Replies: 1
    Last Post: 01-18-2009, 12:42 AM
  3. O2 sensor question
    By slims00ls1z28 in forum External Engine
    Replies: 30
    Last Post: 05-16-2007, 05:23 AM
  4. 02 Sensor question
    By 97ss497 in forum General Help
    Replies: 6
    Last Post: 03-26-2007, 09:36 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •