Results 1 to 11 of 11

My air lid clips keep poping off

This is a discussion on My air lid clips keep poping off within the External Engine forums, part of the LSx Technical Help Section category; Does anyone else have this problem, do i need to buy new ones or wtf. Why when i post it ...

  1. #1
    Member
    Join Date
    Jun 2006
    Location
    Bakersfield, California
    Posts
    152

    red
    1959 corvette

    Unhappy My air lid clips keep poping off

    Does anyone else have this problem, do i need to buy new ones or wtf. Why when i post it doesnt have an arrow or bold blue print by it?
    My mods on the 99 FORMULA
    Whisper lid, K&N, B&M Short Throw, CAI, Magna Flow Exhaust, UMI torque arm, FT LT hdrs, ORY, dual cutouts, 4.11 Gears, BMR SFC, BMR MSB, BMR lower control arms, Poly motor and tranny mounts, 575/568 232/227 111 lobe cam, Taylor wires, ngk tr55s,1 10in. JL W3 for beat.

  2. #2
    Member
    Join Date
    Aug 2005
    Location
    tx
    Age
    37
    Posts
    108

    pewter
    99 trans am ws6

    your lid is properly installed wrong, mine used to do the same thing. i had the lip of the lid sitting in the wrong spot

  3. #3
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    34
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    moving to the external forum.. Do u have smooth bellows? Is this int he vette or a newer car? if its the vette, then just throw a filter directly on the maf or tb if running SD.

  4. #4
    Member
    Join Date
    Jun 2006
    Location
    Bakersfield, California
    Posts
    152

    red
    1959 corvette

    No its on the 99 Formula, and the lid isnt sitting quite right, but ive messed with it plenty of times.

  5. #5
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    34
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    do u have a smooth bellow or fernco or is the air tube still stock?

  6. #6
    Member
    Join Date
    Jun 2006
    Location
    Bakersfield, California
    Posts
    152

    red
    1959 corvette

    No the bellows are not smooth

  7. #7
    Member NHRAMAN's Avatar
    Join Date
    Jul 2006
    Location
    Vancouver,B.C.,Canada.W.Coast
    Posts
    513

    Navy Blue Metallic
    '99 T/A WS6 M6

    Talking

    I have the old slp lid and used to have that problem..I just took 2 sets of needle-nose pliers and bent the clips some more..they are nice and tight now....
    99 WS6 M6 NBM !Cags,!Cats,Vinci/Crane,Hurst,Detroit TruTrac,3:73,31 Splne,Edel.Race LT's,ORY,QTEC,Flow,ARP,Percy,MSD,SLP,AC/DELCO,Bosch,GMPP,Cntrfrce DF,Htchkiss,Susp.Tech,Lakewood,285's,Bilstein,Pro-kit,SLP,RK Sprt,A/Meter,Red Optima,Magnaflow S/S Tips,Hd Pins,Tint,Fire.Ex,[*4 Hot Rod Power Tours*]

  8. #8
    Member
    Join Date
    Jun 2006
    Location
    Bakersfield, California
    Posts
    152

    red
    1959 corvette

    Air tube stock still

  9. #9
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    34
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    that was the next suggestion...

  10. #10
    Member
    Join Date
    Jun 2006
    Location
    Bakersfield, California
    Posts
    152

    red
    1959 corvette

    Get a smooth bellow or fernco?Whats the difference?

  11. #11
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    34
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    i wasnt suggesting to get one. I had the fernco on mine, but it wouldnt allow my lid to seat correctly either. I got rid of it and put the stocker back on. Try bending the clips. If that doesnt work, take a pic so we can see whats going on with it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: These keep poping up while driving
    By Draik in forum Firebird / WS6
    Replies: 13
    Last Post: 08-10-2010, 07:43 PM
  2. Crazy clips "Trans Am, Firebird, Camaro video clips"
    By Richy_Rich67 in forum Firebird / WS6
    Replies: 17
    Last Post: 02-13-2008, 07:52 PM
  3. poping noise
    By ls1speedster in forum Firebird / WS6
    Replies: 2
    Last Post: 12-12-2007, 04:31 PM
  4. poping sound
    By *JC* in forum Suspension and Handling
    Replies: 3
    Last Post: 04-10-2007, 03:04 PM
  5. poping in to say hello
    By zbaron in forum Firebird / WS6
    Replies: 8
    Last Post: 10-30-2006, 03:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •