Results 1 to 7 of 7

to much fuel and back fires

This is a discussion on to much fuel and back fires within the External Engine forums, part of the LSx Technical Help Section category; Ok I put a cam in my car. I had the computer done by texas speed. I have headers and ...

  1. #1
    Junior Member
    Join Date
    Apr 2010
    Location
    PA
    Posts
    22

    Black
    2002

    to much fuel and back fires

    Ok I put a cam in my car. I had the computer done by texas speed. I have headers and air lid stuff like that. Well started it up and it idels fine but when driving it it breaks up and back fires when giving it gas. the plugs are really black and you can see the raw fuel coming out. I change the map sencer and check the air mass. What could be causing this.

  2. #2
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Are you getting any check engine, SES lights?

  3. #3
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    Where in PA are you ? Did you add new injectors also ?

  4. #4
    Junior Member
    Join Date
    Apr 2010
    Location
    PA
    Posts
    22

    Black
    2002

    I am in Altoona. No there the same injectors. Yeah I got a ses light had a cheep scaner do a scan and it said it was the map or air mass senser but put a new map in and the tried the stock air mass still same thing. Could the O2s do this.

  5. #5
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    To Me, it sounds like they cranked up your fuel scales to high, but it could be a number of things... Maybe swap a stock MAF with a buddy, to see if that's the problem.
    I use to have TSP tune mine, years ago, and I bought a spare ecm, so my car didn't have down time. Now, I use HP Tuners... You can even e-mail your tunes...

  6. #6
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Bad 02s can really cripple your performance. It might be a good idea to get a set of new ones and try it. Usually you get a code for the 02s, but its worth a try to swap them.

  7. #7
    Junior Member Devildog1371's Avatar
    Join Date
    Nov 2009
    Location
    Minnesota
    Posts
    14

    Pewter
    01 trans am

    I had back firing when I installed my headers and I tryed everything to try and fix it..... It ended up being when I installed the headers I just barly cracked a spark plug and that was causing the back firing and shitty running.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. West Texas Fires
    By txz28 in forum Almost Anything Goes
    Replies: 26
    Last Post: 04-12-2011, 04:36 PM
  2. Banks And Back Fires what does it meen?????
    By slowride1269 in forum General Help
    Replies: 5
    Last Post: 01-28-2010, 01:22 PM
  3. ZR1 in new camaro fires up
    By noxside in forum Almost Anything Goes
    Replies: 14
    Last Post: 06-26-2009, 05:45 PM
  4. 5 and 7 miss fires
    By VictorG in forum General Help
    Replies: 2
    Last Post: 09-20-2008, 10:12 AM
  5. fires
    By Danger731 in forum Western Members
    Replies: 167
    Last Post: 10-26-2007, 06:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •