Page 1 of 2 12 LastLast
Results 1 to 20 of 32

LT1 rad install in pics

This is a discussion on LT1 rad install in pics within the External Engine forums, part of the LSx Technical Help Section category; I am a member of the pimp boys rewards program......so my recent purchase of new tires really added to my ...

  1. #1
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    LT1 rad install in pics

    I am a member of the pimp boys rewards program......so my recent purchase of new tires really added to my rewards account.......decided to upgrade my rad to a LT1 style.....its really thicker than the LS1 rad.......and a drop in after you fix the LT1 stuff......pimp boys had it in stock.......so I did it that day......the LS1 rad is about 7/8 thick......LT1 is about 1 1/4
    Last edited by sjsingle1; 10-10-2010 at 08:12 PM.

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula


  3. #3
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula



    had a freakin birds nest in there
    Last edited by sjsingle1; 10-10-2010 at 08:06 PM.

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula


  5. #5
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula


  6. #6
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula



    you can see the 1/2 heater hose I used to help plug the lower left hand outlet on the rad......the hose and a brass petcock on the end of it did the trick
    Last edited by sjsingle1; 10-10-2010 at 08:07 PM.

  7. #7
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula



    used a 1/2 to 7/8 plug to fill in the upper right hand hole where the LT1 coolant level sensor goes
    Last edited by sjsingle1; 10-10-2010 at 08:13 PM.

  8. #8
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula



    look ma....no rad.....i also reverse blew out the A/C condenser to get rid of all the crap stuck in the fins......then flushed it with water......it was DIRTY
    Last edited by sjsingle1; 10-10-2010 at 08:15 PM.

  9. #9
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula


  10. #10
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula


  11. #11
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula


  12. #12
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula


  13. #13
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula



    and it all cost less than 100$
    Last edited by sjsingle1; 10-10-2010 at 08:09 PM.

  14. #14
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    Now all you need is the LT1 lol sry, couldn't resist.

  15. #15
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    i could make it a .........V16

  16. #16
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    Quote Originally Posted by sjsingle1 View Post
    i could make it a .........V16
    An Ls/Lt combo 16 cylinder engine I would pay to see that. lol Not to mentoin you would have to blend the LT1 front end of the car onto the LS car to make it all fit lol

  17. #17
    its short but its skinny. jiveass's Avatar
    Join Date
    Oct 2009
    Location
    The Woodlands/spring/houston
    Posts
    2,142

    pewter
    99 trans am

    so do you notice any difference in temp? i know the Ls runs just under 210f...

  18. #18
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    i run a 160 stat.....so no diff in temp...my stock idiot gauge is always around 190......but it has never run hot on me.....not even with all that crap in the rad fins and a/c fins......but i dare it to even think about running hot now

  19. #19
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    U p d a t e
    Last edited by sjsingle1; 02-08-2011 at 08:13 PM.

  20. #20
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    driving home today and that rubber plug in the coolant level sensor hole........CAME OUT....lost at least half the coolant......went to auto zone and got the sensor and plugged it in the hole.......at least i know that wont COME out.......so..........i dont recommend you use a rubber plug in that hole......i dont know if i screwed up the engine .....i looked down and the water temp was pegged......dont know how long it was pegged in a 1/2 hr drive on the highway.......got a tow home to fix it.......seems to be running all right now

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CTS-V Install w/ pics
    By Wesman in forum Suspension and Handling
    Replies: 28
    Last Post: 06-13-2011, 12:43 PM
  2. Header Install in Pics (Pt 2)
    By sjsingle1 in forum External Engine
    Replies: 36
    Last Post: 05-09-2010, 03:14 AM
  3. JL install pics
    By midnightnavyz28 in forum Stereo and Electronics
    Replies: 17
    Last Post: 08-23-2009, 05:29 PM
  4. INSTALL progress pics -- rear well box for 12" -- PICS
    By fredmr85 in forum Stereo and Electronics
    Replies: 0
    Last Post: 05-28-2007, 01:37 PM
  5. SLP Lid install pics
    By bellboa1 in forum Camaro / SS
    Replies: 2
    Last Post: 04-24-2007, 03:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •