Results 1 to 14 of 14

lt help

This is a discussion on lt help within the External Engine forums, part of the LSx Technical Help Section category; i have bine trying to get my new lt's in the car for over a week. i have tryed to ...

  1. #1
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    lt help

    i have bine trying to get my new lt's in the car for over a week. i have tryed to do any thing i can to get them in. i think im going to have to drop the k-member. so has any one had to do this befor? and just how hard is this to do? will i need to get an alinment after i get it back in? i already got the pass side in. i am having all the issues with the driver side. thanks

  2. #2
    Member NoscamaroSS's Avatar
    Join Date
    Oct 2008
    Location
    Durant, Okla
    Posts
    737

    NBM
    2002 Camaro

    What brand?
    02 Camaro
    PRC Stg 2.5 5.3's, Futral F14, PP Typhoon intake, True duals, Performabuilt tranny, & 3500 convertor, HSW plate kit.
    *Old Time* 10.90@ 125mph

  3. #3
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    texas-speed

  4. #4
    Awaiting Activation
    Join Date
    Jun 2008
    Location
    Decatur Al
    Age
    36
    Posts
    135

    NBM
    99 Z28

    Have you tried loosening your motor mount on the drivers side,and jacking the motor up a little bit ? I had to do that when installing my pacesetters. You don't have to take the bolts all the way out just loosen them up a bit.

  5. #5
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    i have done every thing a can to get them in and its just not going.

  6. #6
    MANWHORE TEAM suede's Avatar
    Join Date
    Apr 2007
    Location
    Your Mom's Bedroom
    Posts
    4,548

    Negro
    2000 Trans Am WS.6

    God, i never had to do anything other than take the mantifolds off when i put my Kooks, but some ppl have luck taking off the coil packs and going from the top side? "

  7. #7
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    i tryed that to but still no go. it gets stuck on the head.

  8. #8
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Instailed several brands, never had to tweak the motor or mount or notch or drop the K member. when Lt's first came out for our cars that was the case but not anymore. Do you have enough clearence from the ground? Its all about the angle.
    J
    2001 SS, Its not the car its the Driver that matters....

  9. #9
    MANWHORE TEAM suede's Avatar
    Join Date
    Apr 2007
    Location
    Your Mom's Bedroom
    Posts
    4,548

    Negro
    2000 Trans Am WS.6

    Quote Originally Posted by sunsetorangess View Post
    Instailed several brands, never had to tweak the motor or mount or notch or drop the K member. when Lt's first came out for our cars that was the case but not anymore. Do you have enough clearence from the ground? Its all about the angle.
    J
    I agree, i have put 3 sets on, never had to do more than one set we had to take in from the top but enough kj jelly and some wigling and trial and error they go in....

  10. #10
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    i have all the room i need and no mater the angal it just dosnt want to go in. i am realy p.o. about it now.

  11. #11
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    How high is the car? That header has to almost go in vertically from underneath. What's it hitting, the k-member? Email texas speed and see if they've ever had anyone have problems with the drivers side. There's a square casting tab on the block that I had to trim down when I did my pacesetters.

  12. #12
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    ok i got it in but now im having a bad time of geting the stering shaft back in any tip's.

  13. #13
    MANWHORE TEAM suede's Avatar
    Join Date
    Apr 2007
    Location
    Your Mom's Bedroom
    Posts
    4,548

    Negro
    2000 Trans Am WS.6

    Quote Originally Posted by 01 T/A View Post
    ok i got it in but now im having a bad time of geting the stering shaft back in any tip's.
    Holy shit you had to take off alot of stuff......

    Im gonna say have a buddy turn the wheel little bits while you try to allign it again?

  14. #14
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    i got it on now but i had to sand out some burs that came up on the inside of the rack end of the shaft. thanks evrey one for the help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •