Page 2 of 2 FirstFirst 12
Results 21 to 26 of 26

Low Trac light??!! Need help please!

This is a discussion on Low Trac light??!! Need help please! within the External Engine forums, part of the LSx Technical Help Section category; Originally Posted by Dewman i hit a big bump the other day and bottomed out going about 25-35mph and my ...

  1. #21
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by Dewman View Post
    i hit a big bump the other day and bottomed out going about 25-35mph and my low trac light popped on for 10 seconds and i dont have TCS
    The only time this has ever happened is after I bottomed out pretty damn bad going into that driveway. It was 25 mintues later and it was clunking. Then 2 hours later, Low Trac Light on/off/on/off......on......../off.....on./off.

    I did race that 05 GTO 4 times on the E-way, If something was screwed up, it probably would have shown while racing to 120mph right?

    My TA ran great. Nothing abnormal. But then it thudded real bad 30 minutes after racing, then lights. WTH?

  2. #22
    Member Aetos's Avatar
    Join Date
    May 2008
    Location
    Formerly NYC. Strong Island now!!
    Age
    29
    Posts
    641

    White
    1999 Transam WS6

    Quote Originally Posted by Hi-Po View Post
    Brand new Energy Suspension Poly mount.
    did they charge you a 3% fee?





    My Low Trac light comes on when I have my tcs off and I really don't have traction(ie: my rear is sliding around)

  3. #23
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by Aetos View Post
    did they charge you a 3% fee?





    My Low Trac light comes on when I have my tcs off and I really don't have traction(ie: my rear is sliding around)
    Nah, I am exempt from the 3% fee. Special. Some people just dont know their way around it

    I dont have a button to turn TCS off. The other day when I missed 3rd, my ass end wasnt sliding at all. When I miss a gear (not very often) I just give up. No grind it till you find it shit. My tires chirped, clutch pedal pushed right back in. Its drove find since.

    I think I will just take my Marine buddy out to show him the TA, Home from Iraq tomorrow, and if it acts up/blows up, I will limp/tow home.

  4. #24
    Member Aetos's Avatar
    Join Date
    May 2008
    Location
    Formerly NYC. Strong Island now!!
    Age
    29
    Posts
    641

    White
    1999 Transam WS6

    Quote Originally Posted by Hi-Po View Post
    Nah, I am exempt from the 3% fee. Special. Some people just dont know their way around it

    I dont have a button to turn TCS off. The other day when I missed 3rd, my ass end wasnt sliding at all. When I miss a gear (not very often) I just give up. No grind it till you find it shit. My tires chirped, clutch pedal pushed right back in. Its drove find since.

    I think I will just take my Marine buddy out to show him the TA, Home from Iraq tomorrow, and if it acts up/blows up, I will limp/tow home.
    Damn, don't let luos find out


    Hey, if it breaks it just means its time to upgrade something

  5. #25
    Junior Member WonFastWS6's Avatar
    Join Date
    May 2008
    Location
    Kimberley ID
    Posts
    84

    Pewter
    02 WS6

    have you done anything else to the suspension lately or a rear end

  6. #26
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Nah,


    I drove it today. The low Trac light keeps coming on and in banged on me once. Also, my brakes are very spongy, It might be an exhaust bracket banging around, and maybe I knocked the sensor loose. Thats what Im banking on. I will be getting the car on a lift this weekend hopefully. Totally sucks.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Resetting ABS light w/o trac
    By Whamhammer in forum General Help
    Replies: 0
    Last Post: 04-07-2015, 05:56 PM
  2. Trac off light on
    By derck_mullin in forum General Help
    Replies: 2
    Last Post: 04-22-2009, 06:25 PM
  3. Help: Low Trac light problem
    By Broncoboy9899 in forum General Help
    Replies: 9
    Last Post: 12-05-2008, 09:40 AM
  4. Help: Need Help With P0121 And Trac Off Light
    By glenda in forum Automatic Transmission
    Replies: 4
    Last Post: 05-19-2008, 10:13 PM
  5. Low Trac ?
    By driving in forum General Help
    Replies: 5
    Last Post: 02-11-2007, 11:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •