Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Low Trac light??!! Need help please!

This is a discussion on Low Trac light??!! Need help please! within the External Engine forums, part of the LSx Technical Help Section category; So I was pulling into my girl friends work today, and its a steep incline. Well I thought I just ...

  1. #1
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Low Trac light??!! Need help please!

    So I was pulling into my girl friends work today, and its a steep incline. Well I thought I just bottomed out hitting my exhaust... it made that horrible *thud* sound.

    Well I was driving about 30 minutes later and it went *thud* again. Driving straight, 30 MPH with a state cop behind me lol. I pulled over and couldn't find anything obvious.

    Then about an hour later I raced a 05 GTO a few times, few runs to 120, 4 runs. Then I'm driving home, going straight and *THUD!*, way louder that time. Then a few miles from my house, the Low Trac light was going on and off by its own.


    More info needed, Yesterday I was screwin off and nailed it from 1st. When I went for 3rd my hand slipped off and I missed third. First time since the first day I bought the damn car. Well, the low trac light came on that fuck up, but I immediately disengaged the clutch. The tranny shifts fine, engine runs strong as ever.

    The *THUD* noise is coming from under the center of the dash. What could I have done to cause my low trac light to come on and off when I doing 20 MPH??? I can grab my drive shaft and move it about an inch in each direction with the car in first and parking brake on. Should I be able to do that? If anyone has any ideas on my Low trac light and the loud *THUD*... It would be much appreciated. Thanks,

    Ron.

  2. #2
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    First thought....pumpkin.
    Second thought, tranny.

    Shouldn't be able to move the driveshaft forward and backwards in the car.


    Normally the Low Trac light malfunctions are sensor related. It could be a sensor acting up and throwing on the TCS when it shouldn't. Therefore creating stress on the driveline...and making a clunk.

  3. #3
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by Mr. Luos View Post
    First thought....pumpkin.
    Second thought, tranny.

    Shouldn't be able to move the driveshaft forward and backwards in the car.


    Normally the Low Trac light malfunctions are sensor related. It could be a sensor acting up and throwing on the TCS when it shouldn't. Therefore creating stress on the driveline...and making a clunk.
    NOOO not the pumpkin!!! I really dont think its the rear, the noise is directly under my feet. Passenger side?
    Hopefully not the tranny either.
    The light didnt come on until I was about a mile from home, It never came on during/after/before the THUD's. That sensor easy to change?

    If you thought I meant the driveshaft moving forward(towards the engine) and backward(towards the rear) I mis-spoke. Im talking about rotation, turning. Should it have any play?

    This happened at a bad time, my buddy is coming home from Iraq for 12 days, he has never rode in the TA. Im bummin hard core. So the sensor could be going off and causing this noise?

  4. #4
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Sensors are a cake walk to change. It is on the backside of the axle hub.

    Yes, there is play rotationally in the DS.

  5. #5
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by Mr. Luos View Post
    Sensors are a cake walk to change. It is on the backside of the axle hub.

    Yes, there is play rotationally in the DS.
    Alright, I thought so... I suppose I will go get a sensor tomorrow and change that little fucker. Just weird it only started doing this after pulling into the driveway and bottoming out. That sensor is going to mechanically change something to cause this noise you think?

  6. #6
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    Well take off ASR and see if it still makes that THUD. That will answer your question. Traction control is off then obviously and if it still makes that same noise it wouldnt be the problem we are thinking of.

  7. #7
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by Eric1987 View Post
    Well take off ASR and see if it still makes that THUD. That will answer your question. Traction control is off then obviously and if it still makes that same noise it wouldnt be the problem we are thinking of.
    ASR is Camaro I believe, Also, I dont have a TCS button. Or ASR for that matter. I suppose the only thing I can do is try and swap that sensor out.

    Anyone know of a place that might have one in stock? Im sure GM dealership's have them ,but at an insane price. Anyone know if the sensors are the same for TA and Camaro? How about Gen III?

  8. #8
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Hmmm...

    No TCS...but you are getting the Trac Light....
    ABS light?

  9. #9
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    It says Low Trac.

    Abs light has came on before, but not in quite awhile.


    So, If I do not have a switch for TCS under radio, but I have a Low Trac light... WTF does this mean?

  10. #10
    Member NorthwoodDavid's Avatar
    Join Date
    Dec 2007
    Location
    Arlington
    Posts
    524

    Black
    1999 Trans-Am

    Quote Originally Posted by Mr. Luos View Post
    Hmmm...

    No TCS...but you are getting the Trac Light....
    ABS light?
    Well i dont have traction control, but when i down shift to 3rd and get on it my low trac light comes on, its lower left of the gauges. abs i believe is on the right...i think

  11. #11
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    Wtf they made 4th gens without ASR? I thought only the v6's didnt have it...

  12. #12
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by NorthwoodDavid View Post
    Well i dont have traction control, but when i down shift to 3rd and get on it my low trac light comes on, its lower left of the gauges. abs i believe is on the right...i think
    Thats what I thought? My Low Trac light is in the bottom left corner. My ABS is in on the top Left corner.

    Low Trac is a yellow light

    ABS is a red light.

    I have only gotten a Low trac light when I was stupid and missed a shift. I have seen it twice now.

  13. #13
    Member NorthwoodDavid's Avatar
    Join Date
    Dec 2007
    Location
    Arlington
    Posts
    524

    Black
    1999 Trans-Am

    well my tires arent that good now, so on hiway pulls around 60 65, it breaks loose and the light comes on, i think it only lights up if you spin them in anything other than 1st.

    sound right about the locations too

  14. #14
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Hmmmmm ... just took the car out for a quick five minute spin... No clunks, no lights... WTF!!!

  15. #15
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    I think the low trac light comes on (when you don't have ASR/TCS), it is because a tire locks up, not because you loose traction in a forward motion.

  16. #16
    Member NorthwoodDavid's Avatar
    Join Date
    Dec 2007
    Location
    Arlington
    Posts
    524

    Black
    1999 Trans-Am

    Quote Originally Posted by Mr. Luos View Post
    I think the low trac light comes on (when you don't have ASR/TCS), it is because a tire locks up, not because you loose traction in a forward motion.
    interesting...kinda hard to believe. But ok, i that makes sence too, ill try it next time it rains, bc then i can just over power it and break them loose instead of downshifting and hammering it

  17. #17
    Member Dewman's Avatar
    Join Date
    May 2008
    Location
    Midland, MI
    Posts
    184

    Navy Blue Metallic
    2000 Camaro z28

    i hit a big bump the other day and bottomed out going about 25-35mph and my low trac light popped on for 10 seconds and i dont have TCS

  18. #18
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    My low track light comes on when I slide in rain or snow or sideways... no TCS.

  19. #19
    Junior Member WonFastWS6's Avatar
    Join Date
    May 2008
    Location
    Kimberley ID
    Posts
    84

    Pewter
    02 WS6

    What about the trans mount makes a clunk when its broke and you jump on it or gun it just a thought

  20. #20
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Brand new Energy Suspension Poly mount.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Resetting ABS light w/o trac
    By Whamhammer in forum General Help
    Replies: 0
    Last Post: 04-07-2015, 05:56 PM
  2. Trac off light on
    By derck_mullin in forum General Help
    Replies: 2
    Last Post: 04-22-2009, 06:25 PM
  3. Help: Low Trac light problem
    By Broncoboy9899 in forum General Help
    Replies: 9
    Last Post: 12-05-2008, 09:40 AM
  4. Help: Need Help With P0121 And Trac Off Light
    By glenda in forum Automatic Transmission
    Replies: 4
    Last Post: 05-19-2008, 10:13 PM
  5. Low Trac ?
    By driving in forum General Help
    Replies: 5
    Last Post: 02-11-2007, 11:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •