Results 1 to 10 of 10

Lovin my Longtubes:)

This is a discussion on Lovin my Longtubes:) within the External Engine forums, part of the LSx Technical Help Section category; whats up yall.i just installed my headers last week and had my y pipe fabbed thursday.i should have replaced the ...

  1. #1
    Member Leeroyws6's Avatar
    Join Date
    Feb 2010
    Location
    fort worth
    Posts
    151

    black
    2000 trans am ws6 a4

    Lovin my Longtubes:)

    whats up yall.i just installed my headers last week and had my y pipe fabbed thursday.i should have replaced the motor mounts because they hit the k member a little in first gear.install was a pain in the arse.anyway i took my car to the track friday and it launches like a bat outta hell.(no tune yet).Lts definatley rock.i sucked at the track cause my damn clutch pressure was failing on me.even through i added a rubber protecter to the clutch hydraulic line,and wrapped the primary that runs next to the line.gotta do the drill mod next.anyway,i love my longtubes.just thought i would share.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Nice to hear. I installed our LT's back in March and am still waiting for the first drive.

  3. #3
    Member
    Join Date
    May 2009
    Location
    Manitoba
    Posts
    139

    blue
    1998 Trans Am ls1

    Quote Originally Posted by Leeroyws6 View Post
    whats up yall.i just installed my headers last week and had my y pipe fabbed thursday.i should have replaced the motor mounts because they hit the k member a little in first gear.install was a pain in the arse.anyway i took my car to the track friday and it launches like a bat outta hell.(no tune yet).Lts definatley rock.i sucked at the track cause my damn clutch pressure was failing on me.even through i added a rubber protecter to the clutch hydraulic line,and wrapped the primary that runs next to the line.gotta do the drill mod next.anyway,i love my longtubes.just thought i would share.
    wait till ya get a tune... should almost gain as much from the tune as from the headers. Frost gets my vote, my car hauls some major ass compared to the pre-install! enjoy

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    i like the extra loudness...............as i pass cops

  5. #5
    Junior Member blk_z28's Avatar
    Join Date
    Feb 2009
    Location
    Sacramento
    Posts
    29

    Black
    1999

    I just did headers and a Y pipe on my camaro also and I have the same rubbing problems. Have you replaced the motor mounts yet? Do the headers really need to come back off to finish the job? By the way, I had my car tuned by frost and It made a hudge difference. Long tubes are the way to go.

  6. #6
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Another satisfied customer

  7. #7
    Member Camaro69Mac's Avatar
    Join Date
    Mar 2010
    Location
    Agawam Mass
    Posts
    334

    Black
    69 Camaro, 99 Camaro SS

    Quote Originally Posted by blk_z28 View Post
    I just did headers and a Y pipe on my camaro also and I have the same rubbing problems. Have you replaced the motor mounts yet? Do the headers really need to come back off to finish the job? By the way, I had my car tuned by frost and It made a hudge difference. Long tubes are the way to go.
    What y pipe did you put on? I bought hooker lt headers and am trying to decide what y i should get or just go with the hooker y...also what do you have to do for the tune by frost??? just hook it up to a laptop or something?? i was reading something about a mail order tune

  8. #8
    Junior Member blk_z28's Avatar
    Join Date
    Feb 2009
    Location
    Sacramento
    Posts
    29

    Black
    1999

    I used the pacesetter headers and Y pipe and it went together very easily. The only problem I have is that the Y pipe rubs on the bottom of my car but I am being told that its my motor mounts causing that. Make sure you change your motor mounts while you change your headers. To get your car tuned by frost you go on his web site and choose the things you want done, Then you print a form and list all of the mods you have done to the car and mail your computer to him. It takes about a week to get it back, but its worth it. I had him delete my rear 02 sensors,egr and tune it for my mods. Plus its cheaper and better than buying the preditor tuner and if you ever change your car he will retune for only $50.

  9. #9
    Member Camaro69Mac's Avatar
    Join Date
    Mar 2010
    Location
    Agawam Mass
    Posts
    334

    Black
    69 Camaro, 99 Camaro SS

    [QUOTE=blk_z28;2318865]I used the pacesetter headers and Y pipe and it went together very easily. The only problem I have is that the Y pipe rubs on the bottom of my car but I am being told that its my motor mounts causing that. Make sure you change your motor mounts while you change your headers. To get your car tuned by frost you go on his web site and choose the things you want done, Then you print a form and list all of the mods you have done to the car and mail your computer to him. It takes about a week to get it back, but its worth it. I had him delete my rear 02 sensors,egr and tune it for my mods. Plus its cheaper and better than buying the preditor tuner and if you ever change your car he will retune for only $50.[/QUOT


    That's great I appreciate your help I did order the Hooker y I wanted to match it up I think it should fit well it was kinda expensive 210 but seems good and ill definitely get the tune plus that's awesome he will retune it for that cheap. The before and after the tune was noticeable? ? Any problems so far like with engine light's coming on? I can't wait to get this all done it will be worth the work of doing it myself
    Last edited by Camaro69Mac; 04-30-2010 at 12:12 PM.

  10. #10
    Junior Member blk_z28's Avatar
    Join Date
    Feb 2009
    Location
    Sacramento
    Posts
    29

    Black
    1999

    no problems at all, before I would throw a check engine light when ever I got on the car due to my 02 sensors. Now I have not had a check engine light on since I had the tune.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Still lovin my LQ4 in my '39
    By Wagonmaster2 in forum LSx Retrofit and Swap
    Replies: 4
    Last Post: 10-10-2015, 12:05 PM
  2. lovin the ls1!!!
    By mongosmash in forum New Member Introductions
    Replies: 6
    Last Post: 03-27-2011, 10:16 AM
  3. I'm Lovin It!
    By blackSS01 in forum Almost Anything Goes
    Replies: 7
    Last Post: 12-15-2009, 10:28 PM
  4. not foolin me for your lovin
    By doberman 152 in forum Almost Anything Goes
    Replies: 7
    Last Post: 03-30-2008, 12:48 PM
  5. I'm lovin' it!
    By LS1_TA_2002 in forum Multimedia Section
    Replies: 5
    Last Post: 05-06-2007, 11:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •