Results 1 to 12 of 12

Kooks longtube guys/gals inside

This is a discussion on Kooks longtube guys/gals inside within the External Engine forums, part of the LSx Technical Help Section category; Did you need O2 extenders to install your Kooks??...

  1. #1
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Kooks longtube guys/gals inside

    Did you need O2 extenders to install your Kooks??
    2008 Trailblazer SS
    Yank PTB3600, Kooks 1 7/8" LT's, 4" intake, E-fans, Magnaflow, Sonnax kit, tranny cooler, tune.
    Lowered, HID's, tinted.

    1999 Pontiac Trans Am WS.6 #1747 SOLD
    531.1 RWHP 481.3 FT/Pounds all motor.

  2. #2
    Member
    Join Date
    Sep 2005
    Location
    Pueblo, Colorado
    Posts
    268

    Black
    1998 Pontiac Trans Am

    I would imagine you would probably need them? Are the bungs different on Kooks?

  3. #3
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    The bungs are the same as most LT's.

    Just having a problem connecting the O2's back up to the harness.
    Wonder if those would help it start???

  4. #4
    Member
    Join Date
    Sep 2005
    Location
    Pueblo, Colorado
    Posts
    268

    Black
    1998 Pontiac Trans Am

    You swaped an engine and cant plug in the o2 harness!?! Classic j/p with ya.

    I think that might be playing a large role with the startup though.

    To be serious though...i always have to mess with the harness connections before they go in properly. Its such a bitch plugging them in on the ground IMO. Or maybe a connector in the harness is bent?
    Last edited by ~redlinels1~; 12-25-2005 at 05:36 PM.

  5. #5
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    They plug in fine.

    The wiring just isn't long enough.

  6. #6
    Member
    Join Date
    Sep 2005
    Location
    Pueblo, Colorado
    Posts
    268

    Black
    1998 Pontiac Trans Am

    So they arent long enough even with the extensions? Im a bit confused now. Unless you were just trying to use the o2s without the extensions and its not long enough. If thats the case...I think you answered your own question

    Forgive me...my brain doesnt work very well on break.

    Have you thought about running the rear o2 sensors from a vette? They're very long.
    Last edited by ~redlinels1~; 12-25-2005 at 06:23 PM.

  7. #7
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Yeah...I don't have extensions yet.

    Ordering them early tomorrow. Just wondering if others needed them, making sure I didn't wire them wrong.

  8. #8
    Member
    Join Date
    Sep 2005
    Location
    Pueblo, Colorado
    Posts
    268

    Black
    1998 Pontiac Trans Am

    Took me long enough to realize what you were talking about. lol

  9. #9
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Sorry....not exactly wide awake myself.

    Been a decently long weekend....Busted my ass trying to get the car started, only to have it not happen.
    Oh well...no rush at this point.

  10. #10
    Member
    Join Date
    Sep 2005
    Location
    Pueblo, Colorado
    Posts
    268

    Black
    1998 Pontiac Trans Am

    Its not your fault. I tend to confuse myself......a lot.

    At least you're getting there man. Once it fires up, im sure it will be one of the best moments you have ever had. Knowing you did all of the work on jackstands and the feeling of accomplishment will be amazing.

  11. #11
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Should be good times when it finally fires.
    It was SO close last night....just couldn't get over the fuel being dumped though. There was enough to make me drain the oil out already.
    Not like it was expensive oil....$1.09 AutoZone cheap crap.
    Gonna call TSP tomorrow and see if the guy that sold me the motor can get me the O2 extenders for a good price.

    Even longer night....I was supposed to be leaving shortly to pick up my girl from DIA....but her flight got delayed. Doesn't come in until 11:30 tonight now. Can't wait for tomorrow....mucho relax time.

  12. #12
    Member
    Join Date
    Sep 2005
    Location
    Pueblo, Colorado
    Posts
    268

    Black
    1998 Pontiac Trans Am

    GL with getting it started man. You'll be melting your tires in no time flat.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: ND guys and gals
    By pewter Z28 in forum Mid-West Members
    Replies: 3
    Last Post: 02-03-2011, 03:47 PM
  2. kooks longtube headers and ypipe brand new
    By slpcamaro in forum Parts For Sale / Trade
    Replies: 4
    Last Post: 04-23-2010, 11:09 AM
  3. What else you guys and gals do for fun?
    By nhraformula in forum Almost Anything Goes
    Replies: 63
    Last Post: 06-05-2009, 05:59 PM
  4. Hi Guys and Gals
    By 2002Rumble in forum New Member Introductions
    Replies: 3
    Last Post: 12-21-2007, 07:27 PM
  5. Bye to the Camaro, Hello GTO... and Hi to All You Guys and Gals Again!
    By Tom 06 GTO in forum New Member Introductions
    Replies: 2
    Last Post: 07-30-2006, 10:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •