Results 1 to 5 of 5

intake problems

This is a discussion on intake problems within the External Engine forums, part of the LSx Technical Help Section category; I just installed my weind intake and my car won't idle it just runs rough for a second and dies ...

  1. #1
    Junior Member 97ws6's Avatar
    Join Date
    Aug 2009
    Location
    bridgeport
    Posts
    62

    white
    1997 trans am ws6

    intake problems

    I just installed my weind intake and my car won't idle it just runs rough for a second and dies any input will be apreciated thank you.

  2. #2
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Did you remember to plug in the MAP sensor on the back and get the vacuum lines attached back there?

  3. #3
    Junior Member 97ws6's Avatar
    Join Date
    Aug 2009
    Location
    bridgeport
    Posts
    62

    white
    1997 trans am ws6

    Yes everything is hooked

    up

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    either you left something off or the intake isn't seated all the way down. Check for no leaks between the MAF sensor and the throttle body, all vacuum lines are plugged in with no cracks in the lines (pay particular attention to the backside of the pcv hose), and make sure your intake seated down correctly. I have never installed one of those intakes but do they come with block off's for the rear coolant ports on the heads? Meaning, do the coolant lines run under that intake? Seems like I've read before where someone had trouble getting that intake to seat down correctly.

  5. #5
    Junior Member 97ws6's Avatar
    Join Date
    Aug 2009
    Location
    bridgeport
    Posts
    62

    white
    1997 trans am ws6

    Quote Originally Posted by 0rion View Post
    either you left something off or the intake isn't seated all the way down. Check for no leaks between the MAF sensor and the throttle body, all vacuum lines are plugged in with no cracks in the lines (pay particular attention to the backside of the pcv hose), and make sure your intake seated down correctly. I have never installed one of those intakes but do they come with block off's for the rear coolant ports on the heads? Meaning, do the coolant lines run under that intake? Seems like I've read before where someone had trouble getting that intake to seat down correctly.
    We had to do the ls6 coolant luine mod to make it fit I will check all of the above and get back to you thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. BBK SSI Intake, vs Holley Intake, vs LS6 intake, vs PP 96mm
    By Lunatikgixxer in forum External Engine
    Replies: 26
    Last Post: 02-28-2017, 11:39 AM
  2. Holley intake install problems-help!
    By 350 HRSS in forum External Engine
    Replies: 6
    Last Post: 12-29-2013, 08:06 PM
  3. Difference in Stock Ram Air intake and other aftermarket intake
    By WS6-cobra killer in forum Firebird / WS6
    Replies: 5
    Last Post: 01-15-2007, 07:47 AM
  4. intake manifold problems
    By turbohunter in forum Forced Induction
    Replies: 0
    Last Post: 01-05-2007, 12:50 PM
  5. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •