Page 2 of 2 FirstFirst 12
Results 21 to 29 of 29

Installed headers and throwing a few codes now

This is a discussion on Installed headers and throwing a few codes now within the External Engine forums, part of the LSx Technical Help Section category; I would clear them so you find out if you got the issue fixed sooner. Headers come new with an ...

  1. #21
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    I would clear them so you find out if you got the issue fixed sooner. Headers come new with an oil type coating on them to protect them. Takes a bit to burn that shit off there. It'll just kinda be a hazy type smoke that stinks like shit. It probably wouldn't hurt to stick your head under there and make sure there's no wires touching though just in case.

  2. #22
    Member Sas's Avatar
    Join Date
    Jul 2006
    Location
    Loveland/Ft. Collins, CO
    Age
    38
    Posts
    359

    Blue
    2001 Formula Firehawk

    Thanks for all the info, I really appreciate it! I went back in and re-torqued the headers bolts as well as pulled the plugs out to have a look at them, then re-torqued those back in, and it doesn't smell like it's running rich anymore, and it was a hazy nasty smoke, but it hasn't come back again.

  3. #23
    Senior Member kingls1's Avatar
    Join Date
    Apr 2011
    Location
    Johnstown,PA
    Age
    48
    Posts
    1,102

    Silver
    1999 Trans-Am, 2012 Sonic

    Quote Originally Posted by pajeff02 View Post
    I believe I have several new GM gaskets for the secondary air pipes if you need a set. I tossed my system about 2 years ago and have no need for them.
    Hey Jeff sent you a email have some intrest in air pipe gaskets don't show it ever was sent from my outbox let me know if you got it?

  4. #24
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    We were away for the weekend, so I had not checked our home email. Shoot me an address and I'll drop a set in the mail -- I have no use for them so no cost.

  5. #25
    Member Sas's Avatar
    Join Date
    Jul 2006
    Location
    Loveland/Ft. Collins, CO
    Age
    38
    Posts
    359

    Blue
    2001 Formula Firehawk

    I found some carbon under the passenger side o2 sensor. Could this cause it to run rich now?


  6. #26
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Depends if the hole is large enough for it to suck in outside air. Start the engine with the exhaust system cold and very carefully run your hand around the weld (without touching it!) and you should be able to hear and feel the exhaust puffing out if there is a leak. If you locate your hole, either touch up the weld or use a high temp capable metal epoxy to seal it.

  7. #27
    Member Sas's Avatar
    Join Date
    Jul 2006
    Location
    Loveland/Ft. Collins, CO
    Age
    38
    Posts
    359

    Blue
    2001 Formula Firehawk

    Ok, I'll give that a go and see how bad the leak is. Also sounds like I get to do a valve job next too. Thanks for all the info!

  8. #28
    The Generals Finest Deviant LS1's Avatar
    Join Date
    Nov 2008
    Location
    Tampa
    Posts
    136

    Navy Blue Metallic
    2000 Trans Am

    Looks like you have a few pinhole leaks near the 02 sensor. That fresh air could lead to the 02 sensor reading lean and cause the PCM to dump extra fuel into that bank.

  9. #29
    Member Sas's Avatar
    Join Date
    Jul 2006
    Location
    Loveland/Ft. Collins, CO
    Age
    38
    Posts
    359

    Blue
    2001 Formula Firehawk

    One last problem I'm having now... Is it common for the Texas speed cats to rattle inside?

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Throwing Codes
    By TheChad1371 in forum General Help
    Replies: 1
    Last Post: 07-24-2009, 05:11 AM
  2. Question: Throwing a lot of codes
    By JoshieDoom in forum General Help
    Replies: 5
    Last Post: 03-14-2008, 06:01 AM
  3. Need help, throwing codes!!!
    By rotwiler in forum Computer & Tuning
    Replies: 2
    Last Post: 07-13-2007, 09:44 PM
  4. Headers throwing codes...Please help!!
    By exlrep2002 in forum External Engine
    Replies: 13
    Last Post: 06-10-2007, 08:14 PM
  5. Throwing Codes
    By T/Ajammer in forum Computer & Tuning
    Replies: 2
    Last Post: 09-12-2006, 06:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •