Results 1 to 6 of 6

Hose Clamps - GM or Aftermarket ??

This is a discussion on Hose Clamps - GM or Aftermarket ?? within the External Engine forums, part of the LSx Technical Help Section category; OK... I did a search and found good information on changing out the WP on my 99Z....I am also replacing ...

  1. #1
    Junior Member JJBones's Avatar
    Join Date
    Jun 2009
    Location
    Las Vegas, Nv
    Posts
    26

    Black
    99 Z28

    Red face Hose Clamps - GM or Aftermarket ??

    OK... I did a search and found good information on changing out the WP on my 99Z....I am also replacing the upper and lower rad hoses...
    So the question is based on your experience.... Get NEW metal worm gear type hose clamps or use the GM OEM.....

    Thanks JJBones.....

  2. #2
    Member
    Join Date
    Feb 2008
    Location
    NEW JERSEY
    Posts
    814

    PEWTER
    2001 TRANS AM WS6

    If you use the metal worm ones you need to be carfull not to over tighten them you can crack you stock radiator i just reused the stock ones no problem

  3. #3
    Junior Member JJBones's Avatar
    Join Date
    Jun 2009
    Location
    Las Vegas, Nv
    Posts
    26

    Black
    99 Z28

    So true....

    thanks for the reply.....yes...that is true, since all my other cars have metal radiators...65-66 mustangs.... JJBones..

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I painted and re-used my stock clamps. The heater hose assembly came with new clamps as I recall, but not the radiator hoses. I think the stock style look a whole lot better than the worm-gear.

  5. #5
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    I would just reuse the stock ones, no chance of under or overtightening.

  6. #6
    Junior Member JJBones's Avatar
    Join Date
    Jun 2009
    Location
    Las Vegas, Nv
    Posts
    26

    Black
    99 Z28

    Wink Done.....

    OK....I used all the old OEM hose clamps....now to see if I have any leaks...

    Thanks to all...... Ole JJBones...in SC...where boys will be boys and the pigs always nervous !!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What exhaust clamps should I get?
    By LS1nterceptor in forum External Engine
    Replies: 4
    Last Post: 05-20-2009, 12:57 PM
  2. Help with exhaust clamps
    By slikws6 in forum External Engine
    Replies: 4
    Last Post: 07-09-2008, 05:59 PM
  3. exhaust band clamps
    By bolden3 in forum External Engine
    Replies: 8
    Last Post: 09-29-2007, 06:24 PM
  4. should this hose have clamps on each end?
    By 98z28duval in forum General Help
    Replies: 8
    Last Post: 09-16-2007, 04:41 PM
  5. NAPA has t-bolt clamps...
    By Bad30th in forum Western Members
    Replies: 15
    Last Post: 06-25-2007, 12:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •