Page 1 of 2 12 LastLast
Results 1 to 20 of 30

Horrible Gas Mileage And Rough Driving

This is a discussion on Horrible Gas Mileage And Rough Driving within the External Engine forums, part of the LSx Technical Help Section category; I have 1998 Camaro SS with LT's and ORY. I have these SES codes p0131 p0140 p0151 p0152 p0154 p0160 ...

  1. #1
    Junior Member AF1Strider's Avatar
    Join Date
    Nov 2006
    Location
    albuquerque
    Posts
    61

    Red
    1998 Camaro SS

    Unhappy Horrible Gas Mileage And Rough Driving

    I have 1998 Camaro SS with LT's and ORY. I have these SES codes
    p0131
    p0140
    p0151
    p0152
    p0154
    p0160

    I know they are all O2 sensor codes. THe car will idle rough, almost kill itself, then shoot itslef back up. while driving, it feels like its getting too much air and and bog nasty. Only time it runs good is at WOT, but when i go WOT if you look out the back you see a cloud of black smoke. Do I just need new o2 sensors? or could it be fuel pressure regualtor? or fuses? any advice will help.

  2. #2
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    You need new 02 sensor.
    CCW SP 500s 18x10 275/35 18x11 295/35
    SLP CME with GMMG style catback
    Painted manta stripe

    Quote Originally Posted by konigandy6 View Post
    I'd rather be bi than full homo!!!!

  3. #3
    Member jag42420's Avatar
    Join Date
    Aug 2006
    Location
    Kentucky
    Age
    43
    Posts
    525

    Silver
    2002 WS6 Trans Am

    Quote Originally Posted by Y2KPewterSS View Post
    You need new 02 sensor.

  4. #4
    Junior Member AF1Strider's Avatar
    Join Date
    Nov 2006
    Location
    albuquerque
    Posts
    61

    Red
    1998 Camaro SS

    what kind of o2 snesors should i get? right now they are bosh.

  5. #5
    Senior Member JonB's Avatar
    Join Date
    Sep 2006
    Location
    Florida
    Age
    33
    Posts
    1,458

    Black
    2005 GTO

    Quote Originally Posted by AF1Strider View Post
    what kind of o2 snesors should i get? right now they are bosh.

    I use whatever the parts store has, which is usually bosch.
    05 PBM GTO
    Cold Air Inductions CAI,
    Relocated IAT with omega,
    Slp Predator tune,
    Flowmaster axle back with H pipe,
    Custom tuned TCM.
    BC Racing coil overs


    Sold 01 z28

  6. #6
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Delco

  7. #7
    Junior Member AF1Strider's Avatar
    Join Date
    Nov 2006
    Location
    albuquerque
    Posts
    61

    Red
    1998 Camaro SS

    ok just to add another thing to this, its getting colder, and i have realized when i turn my heater on, my car has no problem at all, it runs fine, all day... does this make any sense?

  8. #8
    Member jag42420's Avatar
    Join Date
    Aug 2006
    Location
    Kentucky
    Age
    43
    Posts
    525

    Silver
    2002 WS6 Trans Am

    How many miles are on your engine, and are you running cats? I'd change o2 sensors ASAP, as the smoke you're seeing will plug your cats (assuming you are running cats). I saw you alrady know they're o2 codes, but thought I'd post these anyway for anyone not familiar...

    P0131 low voltage bank 1 sensor 1
    P0140 insufficient activity bank 1 sensor 2
    P0151 low voltage bank 2 sensor 1
    P0152 high voltage bank 2 sensor 1
    P0154 insufficient activity bank 2 sensor 1
    P0160 insufficient activity bank 2 sensor 2
    Last edited by jag42420; 10-16-2007 at 11:09 AM.

  9. #9
    Junior Member AF1Strider's Avatar
    Join Date
    Nov 2006
    Location
    albuquerque
    Posts
    61

    Red
    1998 Camaro SS

    no im not running cats. i figure i should replace the o2 sensors, but i replaced them about 4 months ago. there bosch oem replacements. i just thought it was how when the heater is on (or a/c) it dosent act up, it drives fine.

  10. #10
    Member jag42420's Avatar
    Join Date
    Aug 2006
    Location
    Kentucky
    Age
    43
    Posts
    525

    Silver
    2002 WS6 Trans Am

    There are several threads on the LS1 forums about problems with the Bosch o2 sensors. Some people run them without any problems. Seems they work well for stockish applications, but not so well for modified cars. I use Delco personally. If they aren't that old, I'd see if they won't warranty them. If they won't I'd contact Bosch.

  11. #11
    Junior Member AF1Strider's Avatar
    Join Date
    Nov 2006
    Location
    albuquerque
    Posts
    61

    Red
    1998 Camaro SS

    yea i think i will try. another thing is my car is 1 1998 SS i hear 98's have alot of problems with LT's especialy with a ORY. right now i have a few exhaust leaks, stupid AIR and EGR, which is going to be getting deleted this week, and where the exhaust hooks up, do to it scraping on all the freaking speed bums in Albuquerque. so im hoping by fixing the exhaust leaks it might help the problem.

  12. #12
    Junior Member AF1Strider's Avatar
    Join Date
    Nov 2006
    Location
    albuquerque
    Posts
    61

    Red
    1998 Camaro SS

    the car has 109xxx miles on it

  13. #13
    Member jag42420's Avatar
    Join Date
    Aug 2006
    Location
    Kentucky
    Age
    43
    Posts
    525

    Silver
    2002 WS6 Trans Am

    Exhaust leaks can definitely cause o2 issues if they're before the o2s...

  14. #14
    Junior Member AF1Strider's Avatar
    Join Date
    Nov 2006
    Location
    albuquerque
    Posts
    61

    Red
    1998 Camaro SS

    well right now the AIR tube bolt broke off and it leaks there, and i think from all the speed bumps in town, i think i may have one where header meets the ORY, i dont know havent had time to crawl underneath the car, with work and my broken hand and all, been kinda rough, im hoping ill get a chance today tho.. fingers crossed!

  15. #15
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by Y2KPewterSS View Post
    Delco
    second that

    2008 Z06 - Velocity Yellow - OEM

    2017 Silverado Z71 5.3 - OEM

    2002 Z06 - Electron Blue Metallic - D1 - E85 - 701 rwhp 687 rwtq **sold**

    2002 Z28: M6 NBM - cam and boltons - 396rwhp 357 rwtq **sold**

  16. #16
    Junior Member AF1Strider's Avatar
    Join Date
    Nov 2006
    Location
    albuquerque
    Posts
    61

    Red
    1998 Camaro SS

    what part stores sell delco, because here in albuquerque, autozone dosent.. so maybe pep boys or checkers??

  17. #17
    Member jag42420's Avatar
    Join Date
    Aug 2006
    Location
    Kentucky
    Age
    43
    Posts
    525

    Silver
    2002 WS6 Trans Am

    Advance, Carquest, and GM dealers sell them where I live...

  18. #18
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by AF1Strider View Post
    what part stores sell delco, because here in albuquerque, autozone dosent.. so maybe pep boys or checkers??

    GM dealers

  19. #19
    Member 180ls1's Avatar
    Join Date
    Jul 2007
    Location
    San Diego (Poway)
    Posts
    516
    1998 Firebird Formula WS6

    i have heard of people running corvette o2 sensors they are supposed to help but i cant remember which ones or why they help

  20. #20
    Junior Member AF1Strider's Avatar
    Join Date
    Nov 2006
    Location
    albuquerque
    Posts
    61

    Red
    1998 Camaro SS

    ok, well i dont have a advance auto parts where im stationed, we have pep boys, napa, autozone, and a checkers, so i guess ill try checkers. if GM sells them i got qouted $151 a piece for those O2's is that right?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Diamond in the rough -- really rough.
    By pajeff02 in forum Classic Muscle
    Replies: 24
    Last Post: 02-03-2011, 09:12 AM
  2. Question: 03 grand am gt horrible fuel mileage
    By SteveCZ28 in forum V6
    Replies: 29
    Last Post: 09-11-2010, 09:19 PM
  3. Help: Horrible gas mileage/brakes squill hardcore
    By izzhemp in forum Firebird / WS6
    Replies: 21
    Last Post: 02-23-2010, 08:27 AM
  4. Is this horrible for my Car.
    By jrc1122 in forum Manual Transmission
    Replies: 21
    Last Post: 07-07-2007, 07:07 AM
  5. Engine runs rough, idles rough, runs rich
    By skintox in forum General Help
    Replies: 2
    Last Post: 08-22-2006, 04:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •