Results 1 to 5 of 5

Help after plug and wire swap

This is a discussion on Help after plug and wire swap within the External Engine forums, part of the LSx Technical Help Section category; I just finished replacing my plugs and wires (except #8) and after I finished I heard a ticking noise after ...

  1. #1
    Junior Member
    Join Date
    Jul 2008
    Location
    San Jose, CA
    Posts
    3

    Sebring Silver
    1998 Z28

    Help after plug and wire swap

    I just finished replacing my plugs and wires (except #8) and after I finished I heard a ticking noise after turning the car off. I'm assuming its just a loose wire, but could it also be a loose plug? I was not able to get a torque wrench in there so I just tightened them a quarter turn past hand tight. How tight should I make the plugs?

  2. #2
    Junior Member 1 TRANS AM's Avatar
    Join Date
    Jun 2008
    Location
    BRENTWOOD TN
    Posts
    96

    BLUE
    02 TRANS AM

    Why did you leave # 8 in? You have to make your way back there and get it. It sounds like you broke a plug. The porcelin around the plug is VERY tender. Get the panties out of your crack and hit the # 8 plug. J/K. Good luck,take your time, for a first timer it will take about 1 hr just for the # 8 plug. You will get better.

  3. #3
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Ticking noise after you turn the car off? Sounds like something besides spark plugs, you have to just find it when you shut the car off. And 1/4 turn after they seat should be fine. When I put my headers on, a friend helped re-install the spark plugs, I heard a ticking sound when the car was running, turned out to be a slightly loose spark plug.

  4. #4
    Junior Member
    Join Date
    Jul 2008
    Location
    San Jose, CA
    Posts
    3

    Sebring Silver
    1998 Z28

    Yea thanks for the help. I got to the last plug just having some trouble pulling the wire off the plug. Plus I snapped the wire so I have to get it done today. Any advice to getting more room in there? I took of the coil packs and the AIR pipe. Going to try again later once I'm less frustrated and my arms dont hurt as much.

  5. #5
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by stevesbucs205 View Post
    Yea thanks for the help. I got to the last plug just having some trouble pulling the wire off the plug. Plus I snapped the wire so I have to get it done today. Any advice to getting more room in there? I took of the coil packs and the AIR pipe. Going to try again later once I'm less frustrated and my arms dont hurt as much.
    Did you try getting it from the bottom?? Thats how I managed to get the number 8 plug in, flex extension and 3/8 drive ratchet from the bottom.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Plug wire recommendations for my LT-1....
    By jrgswhitels1 in forum General Help
    Replies: 3
    Last Post: 08-19-2011, 08:53 AM
  2. Plug and Wire Change
    By Raoul-Duke in forum General Help
    Replies: 11
    Last Post: 07-14-2010, 11:34 AM
  3. Plug wire problems
    By Badbird in forum LT1
    Replies: 8
    Last Post: 07-26-2007, 03:25 AM
  4. Plug Wire Removal
    By KM02SS in forum External Engine
    Replies: 7
    Last Post: 04-11-2007, 08:59 PM
  5. Spark plug wire and plug!
    By RYDER661 in forum General Help
    Replies: 2
    Last Post: 03-13-2006, 10:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •