Results 1 to 5 of 5

HELP!!!!

This is a discussion on HELP!!!! within the External Engine forums, part of the LSx Technical Help Section category; alrite i replace the ps pump start the car, drive it a block and park it look underneath the car ...

  1. #1
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    Unhappy HELP!!!!

    alrite i replace the ps pump start the car, drive it a block and park it look underneath the car and its leaking eveen worse....i go and get a pressure hose the goes from the pump to the rack ....put it on turn the wheels from side to side then fuckin 1 mile from my house the steering wheel almost locks up and i drove it home i used stop leak on my last pump could it have clogged the rack beacuse the powersteering i put in is clear and it is coming out red (the same color as lucas steering rack stop leak shit!)
    Last edited by Firebirdformula; 11-14-2009 at 06:12 PM.

  2. #2
    Junior Member
    Join Date
    Apr 2006
    Location
    Moon, PA
    Age
    36
    Posts
    68

    White
    stolen by "Josh Steel"

    Cheek out your reservoir. I had a similar problem and it was the reservoir. It even ended up frying my altinator because it just keep leaking on it. The plastic weld seems were not very good from the factory. It went on me when my car was about 6 years old. I just broke it apart and used a 2-part apoxy from the department store and I never had the problem ever again. It suprisingly took me a while to figure out it was actualy the reservoir. It does sound like you may have another issue as well if it nearly locked up on you in suck a short period of time. I would sugest cheeking it but it may not solve your problem. It would be a good start though and you might only be out another $2 for the apoxy.

  3. #3
    Junior Member BamBam87's Avatar
    Join Date
    Jun 2009
    Location
    north central illinois
    Posts
    96

    artic white
    2001 trans am ws6

    the only thing i can think of is just clean the area around the reservoir and put fluid in it. without starting it try and see if you can close in where the leak is coming from....if you dont see anything then you gota start the car and just watch to see where its coming from.

  4. #4
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    I posted in your other thread..
    \/\/\/\/\/\/


    any tips on replacing power steering pump??
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  5. #5
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    alrite i figured it out..... the o rings to the reservoir showed up today in a box its in now and hasnt leaked so far! fuckin rediculous!!!
    Last edited by Firebirdformula; 11-17-2009 at 12:06 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •