Results 1 to 7 of 7

Header Install Gone Bad!! Please Help!

This is a discussion on Header Install Gone Bad!! Please Help! within the External Engine forums, part of the LSx Technical Help Section category; Installing lg long tube headers on a 2000 C5 vette. Deleted cats and after install the car runs horrible! Idles ...

  1. #1
    Junior Member
    Join Date
    Nov 2005
    Location
    tennessee
    Posts
    7

    Header Install Gone Bad!! Please Help!

    Installing lg long tube headers on a 2000 C5 vette. Deleted cats and after install the car runs horrible! Idles for a while then drops rpm from 700 to about 200 suddenly and then dies!!! Do 02 sims need to be hooked up for the front o2 sensors or the rear o2 sensors? If rear then are the front ones still used? Also any suggestions???

  2. #2
    Junior Member
    Join Date
    Nov 2005
    Location
    tennessee
    Posts
    7
    ttt

  3. #3
    Tech Junkie hammertime's Avatar
    Join Date
    Nov 2005
    Location
    Belleville, IL
    Posts
    400

    Pewter Metallic
    2001 Camaro SS

    Front O2 sensor needs to remain in place. Those are how the computer gets reference for the air / fuel ratio in closed loop operation.

    Rear O2 sensors are there to check catalyst efficiency. These are the ones the simulators replace.

    Good luck!

    Hammer

  4. #4
    Member
    Join Date
    Aug 2005
    Location
    South of Heaven
    Posts
    139

    Navy Blue Metallic (NBM)
    2002 Camaro SS

    The car needs the front O2 sensors... The sims are only ever for the rears.

  5. #5
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Agreed with both above post its a must to have the front to o2 sensors.

  6. #6
    First I would like to thank JB for posting this, and his help over the weekend doing the install! Could not have done it by myself.

    2nd, thanks for the quick replies! With your input we got it running correct. Although I still have codes, as I was sent the wrong O2 sims. They have the flat connector not the square one. I am in the process of trying to get this corrected. I hope that LGM will sned me the right ones? Can't afford to buy them twice!

  7. #7
    N/A nitrously aspirated stangslayer98's Avatar
    Join Date
    Nov 2005
    Location
    miami,fl
    Age
    36
    Posts
    497

    black
    1998 trans am

    i would get it tuned

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Install shop or DIY header install?
    By dethinboots in forum External Engine
    Replies: 7
    Last Post: 09-24-2011, 07:35 PM
  2. Post LT header install header issues
    By ob02z28 in forum External Engine
    Replies: 20
    Last Post: 02-18-2010, 05:10 PM
  3. header install so cal?
    By sscamed in forum External Engine
    Replies: 0
    Last Post: 10-27-2008, 12:18 AM
  4. Header install, other
    By Tide in forum GTO
    Replies: 0
    Last Post: 03-07-2007, 09:01 AM
  5. Header install
    By linegtdt52 in forum Parts Review
    Replies: 9
    Last Post: 03-09-2006, 01:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •