Results 1 to 3 of 3

Good news and TB questions

This is a discussion on Good news and TB questions within the External Engine forums, part of the LSx Technical Help Section category; Well I wasnt done with all my upgrades but I just had to drive the car.I did get the amp ...

  1. #1
    Member speedracer25f's Avatar
    Join Date
    Nov 2007
    Bethlehem, Pa

    Midnight Blue
    1998 Trans Am

    Good news and TB questions

    Well I wasnt done with all my upgrades but I just had to drive the car.I did get the amp rack mounted, the Throttle body bypassed and ported(which I did myself), also installed the SLP strut brace. It was nice out so I had the collision put back on and I took the car out for a few days. While it was out some guy in a new charger thought he would race me. HA. Dusted him without a problem. Was so nice to drive the car again, been away for over a month. That was the good news. My question, every once in awhile it felt like the throttlebody was sticking. Not bad, and not all the time, just once in a while I would go to pull out and it stuck just a bit. Has anyone else experienced this after porting? Any ideas?

  2. #2
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    doylestown, Pa

    2004 CTS-V

    Who ported it?

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005

    98 Formula
    06 duramax

    did you do the bump stop mod and take the set screw out of the bump stop? Sounds to me like the TB is closing a little to far, try to open it up just a tad with the set screw. Don't open it to much or you'll start to have idle issues. Just sounds like the blade is slamming shut causing it to stick.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts