Results 1 to 4 of 4

Finished the Header install!!!!!

This is a discussion on Finished the Header install!!!!! within the External Engine forums, part of the LSx Technical Help Section category; I finished the header install this morning. I expected it to be a pain in the ass but it was ...

  1. #1
    Junior Member
    Join Date
    Dec 2005
    Location
    Waco, Tx
    Age
    36
    Posts
    58

    Pewter
    1999 Camaro Z28

    Finished the Header install!!!!!

    I finished the header install this morning. I expected it to be a pain in the ass but it was really easy. The entire install and the y-pipe only took 4 hours. Hell I even changed the spark plugs. Granted I had access to all kinds of tools and a lift. My father helped me out and everything went really smooth. The only problem is the y-pipe bangs. It feels like a something grinding when I let the clutch out which I assume that is the pipe vibrating off the floor. Will a piece of heater hose work for now till I can get the bump stop from Thunder Racing? I don't really want the hose to melt or anything. Will it melt? Anyway, the car sounds awesome and it has a lot better throttle response. Only wish I could have left it open headers. Now that is awesome!!!! I really havent got on it hard yet to see if there is a seat of the pants diffrence. All I have to say is Pacesetters install rocks!!!
    Thanks to everyone for the advise and help given in my selection!

  2. #2
    member since may 2000 nhraformula's Avatar
    Join Date
    Dec 2002
    Location
    n/w chicago
    Age
    47
    Posts
    6,933

    black
    2000 nhra edition formula

    the bump stop mod is good. you should also heat up the pipe and bend it abit.
    the problem will go away.
    with a hose, its gonna vibrate like a bitch, i tried that.
    2000 nhra edition formula
    a few bolt ons, 379 rwhp
    11.96 @113.25

  3. #3
    Member keliente's Avatar
    Join Date
    Aug 2005
    Location
    Charlotte, NC
    Age
    33
    Posts
    723
    99 Firebird Formula

    My y-pipe is a piece of crap as well.

    I need to take it down and fix it, but for now I just rapped some rubber hosing around the subframe connector/ y pipe itself to keep it from making noise.

  4. #4
    Junior Member
    Join Date
    Dec 2005
    Location
    Waco, Tx
    Age
    36
    Posts
    58

    Pewter
    1999 Camaro Z28

    Yeah, I put some hose in there and it does vibrate like a bitch but it doesnt make any noise now so this will get me by till monday when I can get it back on the lift.
    99 pewter Z28 M6, SS hood, 10 spokes, Brembo rotors, lid, K&N, Ripper, CAGS, Pacesetter LT's, Borla, TSP ORY-pipe, O2 simulators, STB, SFC's, free mods. Cant forget about my hot fiance in the passenger seat!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Install shop or DIY header install?
    By dethinboots in forum External Engine
    Replies: 7
    Last Post: 09-24-2011, 07:35 PM
  2. Replies: 5
    Last Post: 03-23-2010, 12:00 PM
  3. Post LT header install header issues
    By ob02z28 in forum External Engine
    Replies: 20
    Last Post: 02-18-2010, 05:10 PM
  4. Heads and Cam Install finished :) Idle Video..
    By juiced99ws6 in forum Almost Anything Goes
    Replies: 15
    Last Post: 06-14-2007, 11:14 AM
  5. Replies: 4
    Last Post: 03-15-2007, 12:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •