Results 1 to 10 of 10

Fast 92/92

This is a discussion on Fast 92/92 within the External Engine forums, part of the LSx Technical Help Section category; So last weekend I installed a new FAST 92/92 setup. After what I want to call a small "mishap" I ...

  1. #1
    Member 98camaro's Avatar
    Join Date
    Jun 2007
    Location
    Iowa
    Posts
    270

    Black
    98 Camaro

    Fast 92/92

    So last weekend I installed a new FAST 92/92 setup. After what I want to call a small "mishap" I got everything going fine. Problem is, the car will idle at around 2100 RPM's all the time now. I can basically go 65 down the highway without having to push the pedal. Also, after installing the recommended new coolent line the it calls for, the coolent seems to boil. The car doesn't get hot, but after a few minutes you can hear it boil, and then it runs over. Anyone have a solution?? Also, this is probably in the wrong section..but I wanted people to see it.

  2. #2
    Member
    Join Date
    Nov 2008
    Location
    Cheswick, PA
    Posts
    149

    Silver
    1998 Camaro Z28

    coolant issue sounds like you have an air bubble best to let it idle with the cap off to purge the system

    idle, id check your throttle cable to make sure its not binding and the butterfly is properly shutting

  3. #3
    Member zmg00camaross's Avatar
    Join Date
    Oct 2008
    Location
    missouri
    Posts
    764

    pewter
    2000 camaro ss

    yea check the cable or maybe u screw up a intake gasket and it pulling air in

  4. #4
    Member 98camaro's Avatar
    Join Date
    Jun 2007
    Location
    Iowa
    Posts
    270

    Black
    98 Camaro

    Damn, I was hoping it wasn't an intake gasket, but I am afraid that is what it is. Really not wanting to take it back off, but whatever it takes.

  5. #5
    Member zmg00camaross's Avatar
    Join Date
    Oct 2008
    Location
    missouri
    Posts
    764

    pewter
    2000 camaro ss

    yeah that sucks if you had a scan tool you could read short term fuel trim and spray either or anything flamable really and spray around the intake and if the fuel trim goes crazy then it sucking it somehow like a intake gasket done this on a mustang and worked

  6. #6
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    mine was doing the same thing and when i pluged my predator in, it said that he cable was holding my throttle open %8. so i had to re-drill the throttll bracket and move it forward like a half inch. now after driving it sits at 2k for about 5 sec then goes back down. i tried spraying break clean around the intake to make sure it wasnt leaking and nothing happend, so i hope im ok. gunna get it tuned soon anyway.

    hey did you guys notice that you can hear alot more of the engine through the intake? maybe its just me.

  7. #7
    Member 98camaro's Avatar
    Join Date
    Jun 2007
    Location
    Iowa
    Posts
    270

    Black
    98 Camaro

    I will have to play with the throttle cable some I guess to get it figured out. And yes, I noticed a big difference it sound. With long tubes, it sounds so much better when you really lay into it. Once I get the 150 shot in there, damn it will really be a beast...

  8. #8
    515 HP TrickFlow Package BADASS2000SS's Avatar
    Join Date
    Feb 2008
    Location
    Palm Beach, FL
    Age
    40
    Posts
    1,702

    440 RWHP / 410 TQ
    2000 SLP CAMARO SS

    Keep the intake and TB on. Take the air intake off. Hold your hand over the opening to the TB. If it keeps running, you have an air leak. You can also look in at the butterfly and see if it is sticking open. Try that shit first.
    2000 SLP Camaro SS M6 * 515 HP TrickFlow Package * FAST 92 MM Intake * Nick Williams 92 MM TB * Volant CAI * Granatelli MAF * Full Custom True Dual Exhaust with X-Pipe * Tuned by Breathless Performance

  9. #9
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    Did you find anything? I found a hose with a hole in it. I replaced it but it still does that high idle thing for about 5 sec after I come off the gas. Under the hood it almost sound like I have a leak but it so loud I can't tell. When I put it on I used new gaskets I really hope it's not that. Anything else I could try?

  10. #10
    Member 98camaro's Avatar
    Join Date
    Jun 2007
    Location
    Iowa
    Posts
    270

    Black
    98 Camaro

    I am actually in Colorado on business for three months, and I am not sure when I will be home to play with it. I will keep you updated though.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FAST 90 on LS2
    By Mr. Luos in forum External Engine
    Replies: 1
    Last Post: 11-05-2010, 09:48 AM
  2. 150 mph is a lil fast
    By SycoJoe69 in forum Almost Anything Goes
    Replies: 97
    Last Post: 11-19-2007, 06:45 PM
  3. Ls1 Go Fast Parts*.Needs to go Fast!!
    By king_speed in forum Parts For Sale / Trade
    Replies: 8
    Last Post: 08-08-2007, 01:41 PM
  4. check out this fast ass supra!!! then a crazy fast honda...
    By got-a-ls1 in forum Almost Anything Goes
    Replies: 5
    Last Post: 08-27-2006, 04:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •