Results 1 to 3 of 3

Exhaust banging floor board???

This is a discussion on Exhaust banging floor board??? within the External Engine forums, part of the LSx Technical Help Section category; Need a little help with a 2000 WS6 after installing my exhaust. I installed a set of Kooks long tube ...

  1. #1
    Junior Member
    Join Date
    Feb 2007
    Location
    Temple Texas
    Posts
    57

    Silver
    2000 WS6

    Exhaust banging floor board???

    Need a little help with a 2000 WS6 after installing my exhaust. I installed a set of Kooks long tube headers, a Kooks y-pipe with Magnaflow hi-flow cats and a Magnaflow cat back. Now when you take off in 1st gear and sometimes shifting into 2cnd, the exhaust bangs against floor pan. If this has been covered in another thread please point me in that direction. Thanks.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Hello!

    Exact same setup here on our car. I had a clearance issue with the Y-pipe on the driver side and was able to resolve it with careful adjustment. The fix was to rotate the slip joint on the Y-pipe to obtain maximum clearance where it passes beneath the underbody brace. It's possible that your engine mounts are whooped (especially if they are the stockers) and this causes the engine to drop in the front and forces the exhaust closer to the underside of the car. A set of poly mounts would remedy this issue. Absent either of those fixes, they do make a special bracket to hold the exhaust in place -- I'll go find it and post a link.

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Here's the thread on my Kooks clearance issue: Kooks Y-Pipe Fitment Issue (Pics) See Post #33 for a pic of the bracket.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: water in the driver side floor board
    By TransAmFanatic in forum General Help
    Replies: 12
    Last Post: 11-16-2009, 05:01 PM
  2. banging noise
    By jAgZ28 in forum LT1
    Replies: 10
    Last Post: 09-02-2008, 10:06 PM
  3. T56 troubleshoot banging
    By grandkodiak in forum Manual Transmission
    Replies: 2
    Last Post: 08-25-2008, 03:41 PM
  4. BANGING TRANNY in 2nd,3rd
    By LETHALxLS1 in forum Automatic Transmission
    Replies: 2
    Last Post: 07-16-2007, 03:32 AM
  5. banging off rev limitter
    By Zboner in forum General Help
    Replies: 16
    Last Post: 11-24-2005, 10:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •