Results 1 to 7 of 7

Don't know what's happening.

This is a discussion on Don't know what's happening. within the External Engine forums, part of the LSx Technical Help Section category; My cars been acting up. It's like its misfiring but I'm not completely sure if this is whats going on. ...

  1. #1
    STAY PUFT thecorrectformula's Avatar
    Join Date
    Jun 2007
    Location
    Delaware, OH
    Age
    30
    Posts
    678

    Navy Blue Metallic
    98 Formula

    Don't know what's happening.

    My cars been acting up. It's like its misfiring but I'm not completely sure if this is whats going on. I just installed Longtubes/ORY and a catback, and starting about three weeks afterwards its been acting like it might be misfiring and its down on power. I know for sure that it was misfiring the other day under heavy throttle but I can't really hear it at other times but it still feels the same. Any suggestions on possible problems or fixes.

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Since you just installed LTs I'd check to be sure a plug wire isn't arcing on the header somewhere - happened to a friend of mine on #6 a couple weeks after his SLP install. We found it by starting the car in the dark and reving it. Could be something else but something easy to check. If it was an 02 wire on the header it would be throwing the SES.

  3. #3
    STAY PUFT thecorrectformula's Avatar
    Join Date
    Jun 2007
    Location
    Delaware, OH
    Age
    30
    Posts
    678

    Navy Blue Metallic
    98 Formula

    Okay I'll have to check. I was wondering. It doesn't have the heat shields that usually go around the wire boot by the headers. would that possibly cause it?

  4. #4
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Don't think missing heat shields alone would do that. Most aftermarket plug wires are fine without them.

  5. #5
    Senior Member slims00ls1z28's Avatar
    Join Date
    Apr 2007
    Location
    TN
    Posts
    1,212

    2005 GTO M6 Black
    2000 Z28 A4 Red

    Wire or cracked plug or temp sensor. Been there done that.

  6. #6
    Senior Member Wheeler99WS6's Avatar
    Join Date
    Jul 2006
    Location
    indiana
    Age
    35
    Posts
    1,018

    black, 05 Roush
    black, 99 T/A WS.6

    I had similar symptoms after my header install, I wasnt smart enough to change my plugs while doing my header install. Changed my plugs and no more problem. I agree with said above, I would check the plugs and wires.
    1999 T/A WS6 Black -------SOLD
    05 mustang Roush sport;
    DOB manifold, m122 SC, 47lb injectors, gt500 TB, roush TVS CAI, Detroit rocker SC grind camshafts, Mac LTs, off road x, roush off road mufflers, roush short throw shifter, kenne bell BAP, Brenspeed 93 octane tune. 479rwhp 436ftlbs SAE.

  7. #7
    STAY PUFT thecorrectformula's Avatar
    Join Date
    Jun 2007
    Location
    Delaware, OH
    Age
    30
    Posts
    678

    Navy Blue Metallic
    98 Formula

    Yeah I'll go ahead and change them since I have a brand new set sitting in the garage. Hopefully that'll solve the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. So its happening again.....
    By 95camaroZNC in forum Almost Anything Goes
    Replies: 20
    Last Post: 12-08-2011, 01:10 PM
  2. anyone see this happening to them?
    By 0rion in forum Almost Anything Goes
    Replies: 62
    Last Post: 11-05-2009, 10:40 AM
  3. Well....it is happening...
    By Mr. Luos in forum Almost Anything Goes
    Replies: 33
    Last Post: 11-29-2008, 02:28 PM
  4. why is this happening?
    By stoney2677 in forum Request and Feedback
    Replies: 2
    Last Post: 05-14-2007, 04:19 PM
  5. What is happening!?!
    By JDRedseal in forum New Member Introductions
    Replies: 2
    Last Post: 07-23-2006, 06:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •