Results 1 to 6 of 6

Detached sparkplug wire/Header clicking?

This is a discussion on Detached sparkplug wire/Header clicking? within the External Engine forums, part of the LSx Technical Help Section category; This is a two part question, and i hope you guys can help because it is bugging the hell outta ...

  1. #1
    Member Jon7I2's Avatar
    Join Date
    May 2006
    Location
    Chicago
    Age
    31
    Posts
    307

    Navy Blue Metallic
    99 Formula M6

    Detached sparkplug wire/Header clicking?

    This is a two part question, and i hope you guys can help because it is bugging the hell outta me. I just recently installed Dynatech's LT package on my Formula, and everything was fine for about a week. Then i started to hear a clicking comming from the passenger side collector area. Then the clicking seemed to be comming from the main passenger side header gasket. However, i later found out it wasnt a bad gasket, but 1 of the spark plug wires wasn't completely connected to the coil pack. So essentially the car was firing on 7 cylinders, although i barely drove it during this time. How bad is this for the car? Is there anything i need to be worried about? And what is the clicking comming from the passenger side collector? I know clicking is typically a leak but i retightened the clamp several times, so I'm just stuck. Any help w/ any of these problems would be greatly appreciated.

  2. #2
    Pathelogical Liar BlackLT1Z28's Avatar
    Join Date
    Aug 2006
    Location
    Missouri
    Age
    30
    Posts
    1,476

    Black
    94 Camaro Z28

    The clicking could be your collector hitting the bottom of the car when your driving. And obviously, you're losing power by running 7 cylinders. I would reconnect the plug as soon a possible.

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Don't think you hurt the car, no mention of even a SES light. Exhaust leaks usually make more of a "tapping" noise.

  4. #4
    Member Jon7I2's Avatar
    Join Date
    May 2006
    Location
    Chicago
    Age
    31
    Posts
    307

    Navy Blue Metallic
    99 Formula M6

    I did reconnect the plug as soon as i learned it was not on properly. And no check engine light (SES) came on at all. But the clicking is present even when the car is in netural. I think i have to take it somewhere, because this is really annoying. But thanks for your help

  5. #5
    Pathelogical Liar BlackLT1Z28's Avatar
    Join Date
    Aug 2006
    Location
    Missouri
    Age
    30
    Posts
    1,476

    Black
    94 Camaro Z28

    Could be a lifter tapping.

  6. #6
    Member Jon7I2's Avatar
    Join Date
    May 2006
    Location
    Chicago
    Age
    31
    Posts
    307

    Navy Blue Metallic
    99 Formula M6

    Whats a lifter? Although i think i resolved the situation. I went to a car show today and talked to someone w/ the same header setup. the guy said thats just the way they sound, and he also showed me how to double click the sparkplug wires into the coil packs. So I think everything is fine w/ the car for now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sparkplug?
    By TiGer85SS in forum External Engine
    Replies: 2
    Last Post: 01-25-2010, 06:36 PM
  2. Help: Change Sparkplug?
    By king245249@bellsouth in forum External Engine
    Replies: 8
    Last Post: 03-14-2009, 01:28 AM
  3. Sparkplug wire heat shields
    By Cachels1 in forum General Help
    Replies: 3
    Last Post: 04-28-2008, 11:00 AM
  4. Detached Muffler Survey-------------
    By matthewaqui in forum External Engine
    Replies: 5
    Last Post: 01-29-2008, 04:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •