Results 1 to 10 of 10

code P0300

This is a discussion on code P0300 within the External Engine forums, part of the LSx Technical Help Section category; '99 corvette engine falls flat on it's face for a short period of time then clears itself and seems to ...

  1. #1
    Junior Member
    Join Date
    Dec 2005
    Location
    florida
    Posts
    14

    red
    1999 corvette

    Unhappy code P0300

    '99 corvette engine falls flat on it's face for a short period of time then clears itself and seems to run pretty much ok.While this is going on the exhaust smells horrible.
    Acceleration does not seem as strong as other vettes I have sampled.It seems to come alive but with a little delay.I was cruising at steady 60mph yesterday when it happened, this time it coded p0300 which was multiple random cylinder misfires.It lasted for a couple of miles. This happened when I first bought the car in Nov. and only three times since then but never showing a code.The check engine light flashed a little while before going steady and then the car was running smooth again.
    The engine was changed in Jan. so it has happened with both engines.
    The only reused parts from the old engine were the intake and the fuel injectors.All else was brand new GM out of the box.Plug it in and run.
    I hope some one can help me because this car is about to break the 10k repair bills since nov.

  2. #2
    Still young and dumb 99m6t/a's Avatar
    Join Date
    Apr 2006
    Location
    Kentucky
    Age
    29
    Posts
    16

    Silver
    99 Trans Am

    Man, I posted this same thing up on here about a week ago because my TA does the same thing pretty much but no one really replied to it.

    Hope you have better luck with it.

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    My car has thrown P0300 a couple times over the years, but just cleared the code and hasn't come back for several months now since the last time. Both you guys need to look it up at www.gearchatter.com maybe you can find an answer there.
    A4(3.42)TA Cover/Nittos/Vig 3200/Corsa Catback/FTRA/BMR Boxed SFC, STB, ACLA, APHR/Predator Custom Tune...

  4. #4
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    I can't NOT throw that code.


    It is a random misfire.
    Plugs
    Wires
    O2's
    Fuel
    2008 Trailblazer SS
    Yank PTB3600, Kooks 1 7/8" LT's, 4" intake, E-fans, Magnaflow, Sonnax kit, tranny cooler, tune.
    Lowered, HID's, tinted.

    1999 Pontiac Trans Am WS.6 #1747 SOLD
    531.1 RWHP 481.3 FT/Pounds all motor.

  5. #5
    Junior Member
    Join Date
    Dec 2005
    Location
    florida
    Posts
    14

    red
    1999 corvette

    Try this???

    I have a friend who is a service writer now that he is almost disabled from working on these ground hugging machines. He said it is most likely a fuel delivery problem and that a fuel pressure guage and hose assy should be attached to the fuel rail and taped to the winshield to observe the fuel pressure when the malfunction manifests itself. Record the reading and see if it falls within spec.The fuel pressure with the key turned on to cycle the pump then turned off should be 50-62 lbs. He feels it is a fuel pump getting ready to leave me stranded. The info at gear chatter is helpful if you have a GM scanner toanalyze the info,but it is informative.I am taking the car to the dealer Friday and leaving it until they fix it. I am so over this car. if it was the only thing I owned and it disappeared I wouldn't even go look for it.
    Good luck

  6. #6
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    WOT you want at least 52-53 PSI.

  7. #7
    Junior Member
    Join Date
    Mar 2006
    Location
    Springfield, OH
    Age
    46
    Posts
    3

    Bright Rally Red
    2001 SS Camaro

    P0300 Code is Mutiple Misfires detected

    Try Changing Your Fuel Pressure Regulator Sounds Like The Diafram Is Sticking

    If You Guys Have Any Other ? Feel free to Email Me sstookey@woh.rr.com
    Last edited by Scott Stookey; 06-02-2006 at 06:16 PM.

  8. #8
    Member Flobeast385's Avatar
    Join Date
    Aug 2005
    Location
    NC
    Age
    32
    Posts
    124

    Pewter
    1999 TA M6

    My TA did the same thing and then run fine for a little while so i hooked the GM scan tool up to it at work and one of the O2 sensors was showing high voltage. That solved my problem by replacing it
    99 Trans Am M6
    SLP lid/FRA/TBB/Comp 224/224 581/581 112LSA
    Comp 918s/Comp PRs/Hedman TorkStep LTs
    Custom Y/Exhaust/Pro 5.0

  9. #9
    Junior Member
    Join Date
    Dec 2005
    Location
    florida
    Posts
    14

    red
    1999 corvette

    new code P0420

    Last night I took a leisurely ride for about 50 mi. no problem . Jumped on the throttle got up to 70 mph and cruised it for a few more miles.Got off the main road and on comes the check engine light. Car feels like it has a slight miss so I scanned it again and here it is P0300 and P0420 bank one catalyst below threshold.
    Now what???
    It seems I am chasing a moving target with my ATM card.

  10. #10
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Could be a clogged cat. Check that first.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P0300 misfire code...help:(
    By Lotapwr in forum General Help
    Replies: 7
    Last Post: 05-02-2013, 08:19 PM
  2. P0300 code random misfire...
    By MagicMan in forum General Help
    Replies: 87
    Last Post: 07-31-2009, 02:27 PM
  3. Damn P0300 code again
    By Hurley711 in forum General Help
    Replies: 24
    Last Post: 05-14-2009, 05:17 AM
  4. Question: P0300 Code on 2002 Trans Am WS-6
    By axvick in forum Firebird / WS6
    Replies: 3
    Last Post: 11-23-2008, 04:19 PM
  5. P0300 Code - HELP
    By oldguy in forum GM Trucks
    Replies: 1
    Last Post: 09-05-2007, 06:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •