Results 1 to 7 of 7

cant keep lid shut

This is a discussion on cant keep lid shut within the External Engine forums, part of the LSx Technical Help Section category; ok just put on a whisper lid, the clamps wont hold it down and keep poping off, i have already ...

  1. #1
    Senior Member Zboner's Avatar
    Join Date
    Aug 2005
    Location
    cincinnati/northern ky
    Age
    31
    Posts
    9,045

    Black
    99 SS

    cant keep lid shut

    ok just put on a whisper lid, the clamps wont hold it down and keep poping off, i have already lost one clamp, and they just keep coming off and also coming of tthe back, this is bull shit, what can i do?

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    I had the same issue when I first got mine. Make sure the lid is pushed back as far as it will go, and the upper lip of the lid should be behind the lower lip of the air box. Once the lid "forms" to the air box you can take it on and off without any problems.

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Just saw a PN for the clamps on another board in case you need it: 25043286 PKG of 6.

  4. #4
    Senior Member Zboner's Avatar
    Join Date
    Aug 2005
    Location
    cincinnati/northern ky
    Age
    31
    Posts
    9,045

    Black
    99 SS

    it is all the way back and keeps coming off, i dave no idea what the problem is

  5. #5
    TA Nut BlackTAWS6's Avatar
    Join Date
    Aug 2005
    Location
    Waco, TX
    Age
    36
    Posts
    136

    Black
    2002 Trans Am WS6

    Just a little something to check also, might help, make sure the seal is on evenly and correctly.

    Billy

  6. #6
    DetroitDrillSGT
    Guest
    I had the same problem, I had a gasket that came with the filter I bought and put that on, made it nice and tight and the clips dont come off now.


  7. #7
    Senior Member Zboner's Avatar
    Join Date
    Aug 2005
    Location
    cincinnati/northern ky
    Age
    31
    Posts
    9,045

    Black
    99 SS

    thanks guys, mine still wont shut, i guess ill be using some Kentucky Chrome on it..j/k

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SS wont shut off?/.,!% HELP
    By ssweet99ss in forum General Help
    Replies: 7
    Last Post: 05-21-2008, 03:41 PM
  2. Motor shut down
    By 2kflhr in forum General Help
    Replies: 15
    Last Post: 02-21-2008, 05:09 AM
  3. Hatch will not Shut!!!!!!
    By Pewter WS-6 in forum General Help
    Replies: 11
    Last Post: 12-07-2007, 09:28 PM
  4. Srt-4 Shut Down
    By 99BadAzzSS in forum Kill Stories
    Replies: 37
    Last Post: 08-07-2007, 10:44 AM
  5. Shut it down please
    By oneBADDz in forum Request and Feedback
    Replies: 1
    Last Post: 01-08-2006, 07:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •