Results 1 to 4 of 4

Belt Issue

This is a discussion on Belt Issue within the External Engine forums, part of the LSx Technical Help Section category; My power band is super high, peak HP is at about 6700. Problem... Whenever the motor is kept at such ...

  1. #1
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007

    2000 / SS

    Belt Issue

    My power band is super high, peak HP is at about 6700. Problem... Whenever the motor is kept at such high RPMs I have a belt slipping issue. The belt will start to make noise, I pop the hood, and find the belt half way off the pulley.

    Will an adjustable tensioner solve the problem?

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Bragg NC

    Met. Sunset Orange
    01 SS

    What condition is the belt in? Are all of your pulleys instailed correctly?
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Member 666ws6's Avatar
    Join Date
    Oct 2005
    Greenville, SC

    2000 Trans Am Ws6 #2946

    I had a similar problem. At high RPM, the engine would throw the belt. Mostly once the belt had a few miles on it. But, I found the tensioner would wobble or go irradic and allow the belt to come off. (I filmed it under the hood.) I think there was a link on youtube of a similar one.

    Anyway, I bought Katech Engineering LS1 tensioner and it looks good now. Haven't had the belt problem again since.

  4. #4
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005

    1999 TA WS.6

    I had that problem with my (non) high revving 6.0. Put it to about 6400 RPM and it slipped two ribs once. I bought the Katech Solid tensioner. Haven't had one problem since. Great piece.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HOW TO: Replacing a Broken Seat Belt Guide
    By BANDITCAR in forum General Help
    Replies: 32
    Last Post: 08-12-2016, 04:19 PM
  2. AC Belt chirp & ON/oFF issue
    By eautocad in forum General Help
    Replies: 10
    Last Post: 10-31-2007, 04:19 PM
  3. '00 WS/6 Belt problems.
    By JWSmythe in forum General Help
    Replies: 6
    Last Post: 05-26-2007, 10:35 AM
  4. serpentine belt help!!
    By 2kss in forum Camaro / SS
    Replies: 7
    Last Post: 01-06-2007, 09:45 AM
  5. Excessive Belt problems? Check this out..
    By AKIRA in forum General Help
    Replies: 5
    Last Post: 11-21-2006, 06:28 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts