Results 1 to 2 of 2

bad fuel pump???

This is a discussion on bad fuel pump??? within the External Engine forums, part of the LSx Technical Help Section category; on my T/A, fuel is not getting to my injectors. i had blown both fuel injector fuses, replaced them, and ...

  1. #1
    386HP 373TQ jwindbigler's Avatar
    Join Date
    Dec 2005
    Location
    San Diego...Michigan originally
    Age
    34
    Posts
    1,426

    Pewter
    1999 Trans Am 5.7L

    bad fuel pump???

    on my T/A, fuel is not getting to my injectors. i had blown both fuel injector fuses, replaced them, and the car still wont start. i have a mis-indication with my fuel level. it says that im empty. to be sure i added 5 gallons to the tank. is this a sign that i have a bad fuel pump, or could it be a relay.

  2. #2
    386HP 373TQ jwindbigler's Avatar
    Join Date
    Dec 2005
    Location
    San Diego...Michigan originally
    Age
    34
    Posts
    1,426

    Pewter
    1999 Trans Am 5.7L

    replaced relay, fuel pump is good

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pump fuel guage issues on my '02 B4C
    By ANDYZ28 in forum Camaro / SS
    Replies: 7
    Last Post: 12-29-2014, 11:30 AM
  2. Pontiac Fuel Pumps - Do You Have The Right Fuel Pump?
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 03-15-2011, 10:20 PM
  3. LS1 all yr fuel injectors, oe fuel rail, pump,more
    By Frost in forum Parts For Sale / Trade
    Replies: 7
    Last Post: 04-27-2009, 03:26 PM
  4. Replies: 3
    Last Post: 10-02-2006, 07:23 PM
  5. Fuel Pump Pump Problem?????? Help!
    By undertakersT/A in forum General Help
    Replies: 4
    Last Post: 04-24-2006, 10:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •