Results 1 to 2 of 2

Back fire

This is a discussion on Back fire within the External Engine forums, part of the LSx Technical Help Section category; Hey guys I am having trouble with back firing with my LS1 02 SS. i was out of town for ...

  1. #1
    Member SS201's Avatar
    Join Date
    Apr 2009

    2002 Chevy Camaro SS

    Back fire

    Hey guys I am having trouble with back firing with my LS1 02 SS. i was out of town for two weeks, I used the car for two days and now its back firing a lot. Just accelarating moderately to speed up to about 30 or so it back fires. Does anyone know what may be the culprit?
    2002 Camaro SS, Hooker Exhaust, Pacesetter Headers, Drag Dump, TSP Magic Stick 4, Comp Cams valve train, GM LS6 Intake Manifold, High Volume Fuel Pump, MTI Intake, K&N Air Filter, 3600 Stall, sub-frame connectors... still working on new wheels

  2. #2
    Junior Member
    Join Date
    Dec 2007
    Austin, TX

    2002 Trans am WS6 T-top

    Do you still have your diverter valves intact (air pump system) Is the check engine light on/ blinking?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to Replace the Radiator in your LT1
    By 95camaroZNC in forum LT1
    Replies: 9
    Last Post: 09-24-2008, 05:07 PM
  2. Coleman Roddy looses all Memorabilia in fire.
    By PapaG in forum Drag Racing
    Replies: 0
    Last Post: 06-03-2008, 10:10 AM
  3. My Ws6 is Back! Cobra,DSM,STI,600cc,TT350z,v6 Fire
    By My Ws6 in forum Kill Stories
    Replies: 5
    Last Post: 05-07-2008, 04:00 PM
  4. 2008 Corvette Shows and Events
    By Ed Blown Vert in forum Corvette
    Replies: 0
    Last Post: 03-04-2008, 02:00 PM
  5. is this real or fake?
    By FSANE in forum Almost Anything Goes
    Replies: 4
    Last Post: 04-06-2007, 08:36 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts