Results 1 to 5 of 5

Alternator issues. again.

This is a discussion on Alternator issues. again. within the External Engine forums, part of the LSx Technical Help Section category; So my alternator went out today. for the second time. just stopped charging. belt has tension, alt is turning, etc. ...

  1. #1
    Fear The Reaper IceeWS6's Avatar
    Join Date
    Jan 2010
    Location
    Asheville, NC
    Posts
    138

    Pewter Metallic
    '02 WS6 M6 - The Reaper

    Alternator issues. again.

    So my alternator went out today. for the second time. just stopped charging. belt has tension, alt is turning, etc. first one went bad on the dyno. cyrrent alt is reman model.

    is this a common problem with these cars? if so, why does it happen and how can i prevent it?

    02 ws6, lq9 stroker.

    also, would underdrive pulleys affect this?

  2. #2
    Fear The Reaper IceeWS6's Avatar
    Join Date
    Jan 2010
    Location
    Asheville, NC
    Posts
    138

    Pewter Metallic
    '02 WS6 M6 - The Reaper

    if i had looked at current threads i could have answered my own question lol.

    my power steering pump is slightly leaking, which in turn has ruined my alternator. yay, two parts to replace/fix. ugh.
    '02 Pontiac Trans Am WS6 M6
    550rwhp 480rwtq
    more on the waaay


  3. #3
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    glad you figured it out.

  4. #4
    autoconnectionllc.com 02transamce's Avatar
    Join Date
    Nov 2008
    Location
    Montgomery,Ala
    Posts
    2,436

    2007 Corvette
    Ebony

    make sure the pump is leaking before you replace it,the ps hose leaking is much more common.also check rockauto .com for parts,they have quality parts and low prices.
    Posted via Mobile Device

  5. #5
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    I got a couple of stickies in the General section that may help you. Could be a 0.80 cent O-ring.

    As far as the alternator try using some electronic cleaner to get some of the fluid out. It may still be salvageable.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bad alternator solved my years of issues
    By rotwiler in forum Camaro / SS
    Replies: 5
    Last Post: 10-15-2012, 06:17 AM
  2. What can cause my alternator to do this?
    By Firebirdformula in forum Stereo and Electronics
    Replies: 12
    Last Post: 07-04-2010, 07:00 PM
  3. Question: Alternator MAJOR ISSUES! Please help at mywits end
    By TrickedOutSS in forum General Help
    Replies: 9
    Last Post: 06-17-2009, 12:25 PM
  4. Alternator issues - excitor wire reading 10V
    By 01 SS Vert in forum External Engine
    Replies: 0
    Last Post: 03-27-2009, 03:26 PM
  5. alternator
    By a10beav in forum GTO
    Replies: 2
    Last Post: 09-26-2006, 09:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •